# 0.4.0 Server Pure - USB upgrade - ERROR: defrag failed on ... No space left on device

**URL:** https://community.start9.com/t/0-4-0-server-pure-usb-upgrade-error-defrag-failed-on-no-space-left-on-device/5418
**Category:** StartOS Support
**Created:** [July 26, 2026, 6:45am UTC](https://community.start9.com/t/0-4-0-server-pure-usb-upgrade-error-defrag-failed-on-no-space-left-on-device/5418 "2026-07-26T06:45:28Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![passbanish](https://community.start9.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@passbanish](https://community.start9.com/u/passbanish)
#### Post date: [July 26, 2026, 6:45am UTC](https://community.start9.com/t/0-4-0-server-pure-usb-upgrade-error-defrag-failed-on-no-space-left-on-device/5418/1 "2026-07-26T06:45:28Z")

</div>

I have two Server Pure and they each appeared to fail the OTA update and I successfully restored my first test system using USB restore. I did a USB restore on the second system and it worked all day to restore while preserving data by converting the fs to btfrs. I came back to my web console(`start.local/loading`) of the restore process and it filled the browser with these errors:

`ERROR: defrag failed on /media/startos/data/package-data.convert-tmp/volumes/… : No space left on device`

At the start of the update this NVMe had ~180GB of 2TB free. Is it possible to chroot and remove all the bitcoin blockchain data and finish the restore cleanup?

---

<div class="post-metadata">

### Author: ![passbanish](https://community.start9.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@passbanish](https://community.start9.com/u/passbanish)
#### Post date: [September 21, 2026, 7:24am UTC](https://community.start9.com/t/0-4-0-server-pure-usb-upgrade-error-defrag-failed-on-no-space-left-on-device/5418/2 "2026-09-21T07:24:48Z")

</div>

Updating this thread in case this is someones google result. The issue was resolved by doing the upgrade _ **again** _ via USB, and it didn’t encounter the out of space issue again. It just works.

---

<div class="post-metadata">

### Author: ![system](https://community.start9.com/uploads/default/original/1X/2dcde8aa6ad3ce3d7873096ee4b3e5395e19a7b5.png) [@system](https://community.start9.com/u/system)
#### Post date: [September 23, 2026, 7:25am UTC](https://community.start9.com/t/0-4-0-server-pure-usb-upgrade-error-defrag-failed-on-no-space-left-on-device/5418/3 "2026-09-23T07:25:17Z")

</div>

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.
