Bitcoin Core unreliable - time outs very often

Bitcoin Core is very unreliable with time outs happening very often. All blockchain took around 12 days to download. It is so unreliable that I can’t really use JAM or Electrum

My system is a Lenovo E14 g3 laptop with a 2TB USB SSD drive with StartOS 0.3.4.

It is connected to a wifi router via LAN which is connected to my main router via LAN. I haven’t had any problems with LAN or wifi for that matter with this seup, but you never know?

Please help🙏🏻

Hello lachr,

Can you provide the results of your network speed test?

Can you provide more details about your connectivity to the internet? do you have any special software firewall on your router?

From a terminal in windows/mac/linux client , can you run a permanent ping test to e.g.
$ ping -c10000

And provide the results?


Ran the script. It reports around 20 ms…

Do you have any issues when connected directly to your main router via ethernet? Esoteric network setups can often cause issues, and obviously it is very difficult for us to troubleshoot them, due to the added complexity.

I tried connecting directly to the main router. Same problem. Now I need to call my IP to ask if they have a firewall on it. I can’t get acces myself :man_shrugging:t3:

To be continued :+1:t3:

Thank you for sharing the latency information but more important will be the full output as it will show the % of packets as well as packet loss if any.

Also, can you share more details, such as the OS you are testing your internet connectivity from? try to avoid using wireless and connect with an ethernet cable, the node should also be connected via wired to your router, absolutely preferred.


1 Like

Tried to connect homeserver to another LAN. Same problem with unreliable Bitcoin Core. Could it be this istead (see picture)?

@lachr that error in your screenshot means you just lack the video drivers to do kiosk mode. It shouldn’t affect bitcoin core.

What do you mean exactly by Bitcoin Core “time outs happening very often”? Can you provide a screenshot of that error?

This post may also be of interest to you: