# Cannot setup Backup with network share

**URL:** https://community.start9.com/t/cannot-setup-backup-with-network-share/102
**Category:** StartOS Support
**Created:** [December 20, 2022, 9:10am UTC](https://community.start9.com/t/cannot-setup-backup-with-network-share/102 "2022-12-20T09:10:00Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![start9noob](https://community.start9.com/letter_avatar_proxy/v4/letter/s/6a8cbe/32.png) [@start9noob](https://community.start9.com/u/start9noob)
#### Post date: [December 20, 2022, 9:10am UTC](https://community.start9.com/t/cannot-setup-backup-with-network-share/102/1 "2022-12-20T09:10:00Z")

</div>

Before I go on the path and clutter the github issue page with a bug I want to make sure it is not something I need to tweak in my enviorment.

The issue: I cannot mount CIFS throught the frontend or the embassy-cli but I have no issues to mount through mount command but that does not solve backups. Any clue what I can do to proceed? Could I fake an external device by moutning to a path?

**The Enviroement:**  
Raspberry PI: Plan9 (git revision: 92cd85b2043bde1e91cdb3caa4becc2ebcc44009)  
Synology: CIFS sharing  
they are on different VLANs but routing without any limits for TCP and UDP

I can mount without any problem through the terminal but that does not solve any magic encrypted backups

```auto
mount -t cifs -o username=backup_user,password=secretpassword //192.168.100.10/start9_backup /tmp/test

```

## The result from using embassy-cli

```auto
start9@embassy:~ $ sudo embassy-cli backup target cifs add 192.168.100.10 /start9_backup/ backup_user secretpassword
Network Error:

```

## The result from frontend

Error in the UI

```auto
Error
RPC ERROR: Network Error

```

URL: [https://embassy.local/rpc/v1](https://embassy.local/rpc/v1)

The payload

```auto
{
    "method":"backup.target.cifs.add",
    "params":
    {
        "hostname":"192.168.100.10",
        "path":"start9_backup",
        "username":"backup_user",
        "password":"secretpassword"
    }
}

```

## Response

```auto
{
    "jsonrpc":"2.0",
    "error":
        {
            "code":9,
            "message":"Network Error",
            "data":
            {
                "details":"",
                "debug":"\n 0: \u001b[91m\u001b[0m\n\nLocation:\n \u001b[35msrc/util/mod.rs\u001b[0m:\u001b[35m57\u001b[0m\n\n ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ SPANTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━\n\n 0: \u001b[91membassy::disk::mount::filesystem::cifs\u001b[0m\u001b[91m::\u001b[0m\u001b[91mmount_cifs\u001b[0m with \u001b[96m\u001b[3mhostname\u001b[0m\u001b[2m=\u001b[0m\"192.168.100.10\" \u001b[3musername\u001b[0m\u001b[2m=\u001b[0m\"backup_user\" \u001b[3mmount_type\u001b[0m\u001b[2m=\u001b[0mReadOnly\u001b[0m\n at \u001b[35msrc/disk/mount/filesystem/cifs.rs\u001b[0m:\u001b[35m36\u001b[0m\n 1: \u001b[91membassy::disk::mount::guard\u001b[0m\u001b[91m::\u001b[0m\u001b[91mmount\u001b[0m with \u001b[96m\u001b[3mmount_type\u001b[0m\u001b[2m=\u001b[0mReadOnly\u001b[0m\n at \u001b[35msrc/disk/mount/guard.rs\u001b[0m:\u001b[35m85\u001b[0m\n\nBacktrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.\nRun with RUST_BACKTRACE=full to include source snippets.",
                "revision":null
            }
        },
    "id":null
}

```

### Debug message in the JSON payload cleaned up for readibility

```auto

   0:
    Location:
   src/util/mod.rs:57

  ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ SPANTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

   0: embassy::disk::mount::filesystem::cifs :: mount_cifs with hostname=\"192.168.100.10\" username=\"backup_user\" mount_type=ReadOnly 
      at src/disk/mount/filesystem/cifs.rs:36
   1: embassy::disk::mount::guard :: mount with mount_type=ReadOnly
      at src/disk/mount/guard.rs:85

        Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.

```

---

<div class="post-metadata">

### Author: ![start9dave](https://community.start9.com/user_avatar/community.start9.com/start9dave/32/6_2.png) [@start9dave](https://community.start9.com/u/start9dave)
#### Post date: [December 30, 2022, 1:55am UTC](https://community.start9.com/t/cannot-setup-backup-with-network-share/102/2 "2022-12-30T01:55:27Z")

</div>

I would suspect your network setup here - can you put them on the exact same network (to test) and let us know if that solves the problem?

---

<div class="post-metadata">

### Author: ![start9noob](https://community.start9.com/letter_avatar_proxy/v4/letter/s/6a8cbe/32.png) [@start9noob](https://community.start9.com/u/start9noob)
#### Post date: [August 18, 2023, 10:20am UTC](https://community.start9.com/t/cannot-setup-backup-with-network-share/102/3 "2023-08-18T10:20:40Z")

</div>

This is solved in StartOS version 0.3.4.4  
With the change of

- Use IP addresses for Network Folder Backups
