# Error Log Initiating electrs Service

**URL:** https://community.start9.com/t/error-log-initiating-electrs-service/1124
**Category:** StartOS Support
**Created:** [February 12, 2024, 9:55am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124 "2024-02-12T09:55:52Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 12, 2024, 9:55am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/1 "2024-02-12T09:55:53Z")

</div>

Here is the log I am getting. Initiating electrs to the full node repeatedly fails. Any tips? All settings for configuration of the node including password are set to default. Thanks.

electrs log

2024-02-12T02:50:54-07:00 Starting electrs 0.10.2 on x86\_64 linux with Config { network: Bitcoin, db\_path: “./db/bitcoin”, db\_log\_dir: None, daemon\_dir: “/root/.bitcoin”, daemon\_auth: UserPass(“bitcoin”, “”), daemon\_rpc\_addr: 172.18.0.77:8332, daemon\_p2p\_addr: 172.18.0.77:8333, electrum\_rpc\_addr: 0.0.0.0:50001, monitoring\_addr: 127.0.0.1:4224, wait\_duration: 10s, jsonrpc\_timeout: 15s, index\_batch\_size: 10, index\_lookup\_limit: None, reindex\_last\_blocks: 0, auto\_reindex: true, ignore\_mempool: false, sync\_once: false, skip\_block\_download\_wait: false, disable\_electrum\_rpc: false, server\_banner: “Welcome to electrs 0.10.2 (Electrum Rust Server)!”, signet\_magic: f9beb4d9, args: }  
2024-02-12T02:50:54-07:00 [2024-02-12T09:50:54.341Z INFO electrs::metrics::metrics\_impl] serving Prometheus metrics on 127.0.0.1:4224  
2024-02-12T02:50:54-07:00 [2024-02-12T09:50:54.341Z INFO electrs::server] serving Electrum RPC on 0.0.0.0:50001  
2024-02-12T02:50:54-07:00 [2024-02-12T09:50:54.412Z INFO electrs::db] “./db/bitcoin”: 63 SST files, 0.000064301 GB, 0.000000021 Grows  
2024-02-12T02:50:54-07:00 [2024-02-12T09:50:54.667Z INFO electrs::db] closing DB at ./db/bitcoin  
2024-02-12T02:50:54-07:00 Error: electrs failed  
2024-02-12T02:50:54-07:00  
2024-02-12T02:50:54-07:00 Caused by:  
2024-02-12T02:50:54-07:00 0: bitcoind RPC polling failed  
2024-02-12T02:50:54-07:00 1: daemon not available  
2024-02-12T02:50:54-07:00 2: JSON-RPC error: transport error: unexpected HTTP code: 401

bitcoin core log

2024-02-12T02:53:05-07:00 2024-02-12T09:53:05Z ThreadRPCServer incorrect password attempt from 172.18.0.82:46898

---

<div class="post-metadata">

### Author: ![Rick](https://community.start9.com/user_avatar/community.start9.com/rick/32/339_2.png) [@Rick](https://community.start9.com/u/Rick)
#### Post date: [February 12, 2024, 12:26pm UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/2 "2024-02-12T12:26:14Z")

</div>

Is your Bitcoin Core fully synced with all green health checks?

---

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 12, 2024, 2:11pm UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/3 "2024-02-12T14:11:52Z")

</div>

Copy that yes sir. It is accepting incoming peer connections and cranking away.

---

<div class="post-metadata">

### Author: ![George](https://community.start9.com/user_avatar/community.start9.com/george/32/91_2.png) [@George](https://community.start9.com/u/George)
#### Post date: [February 13, 2024, 7:29pm UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/4 "2024-02-13T19:29:04Z")

</div>

Go to Services \> electrs \> Config \> Save

That should reset the password it’s attempting to use to authenticate to the Bitcoin Core RPC.

---

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 14, 2024, 3:14am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/5 "2024-02-14T03:14:30Z")

</div>

You sir are awesome. Thank you. It is syncing.

---

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 17, 2024, 9:26am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/6 "2024-02-17T09:26:46Z")

</div>

Logs are normal now. No error. Thanks man.

---

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 17, 2024, 9:27am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/7 "2024-02-17T09:27:49Z")

</div>

Shoot I spoke too soon.

ThreadRPCServer incorrect password attempt from 172.18.0.97:35972  
2024-02-17T02:26:43-07:00 2024-02-17T09:26:43Z ThreadRPCServer incorrect password attempt from 172.18.0.97:35980  
2024-02-17T02:27:13-07:00 2024-02-17T09:27:13Z ThreadRPCServer incorrect password attempt from 172.18.0.97:33788  
2024-02-17T02:27:14-07:00 2024-02-17T09:27:14Z ThreadRPCServer incorrect password attempt from 172.18.0.97:33792  
2024-02-17T02:27:14-07:00 2024-02-17T09:27:14Z ThreadRPCServer incorrect password attempt from 172.18.0.97:33806  
2024-02-17T02:27:38-07:00 2024-02-17T09:27:38Z ThreadRPCServer incorrect password attempt from 172.18.0.97:46274  
2024-02-17T02:27:38-07:00 2024-02-17T09:27:38Z ThreadRPCServer incorrect password attempt from 172.18.0.97:46288

---

<div class="post-metadata">

### Author: ![mccutch1](https://community.start9.com/letter_avatar_proxy/v4/letter/m/d9b06d/32.png) [@mccutch1](https://community.start9.com/u/mccutch1)
#### Post date: [February 17, 2024, 9:34am UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/8 "2024-02-17T09:34:59Z")

</div>

Figured it out. Had to do a similar config/save on Mempool service. After stopping and restarting it. Mempool sync was hung. Thanks.

---

<div class="post-metadata">

### Author: ![Vancity](https://community.start9.com/letter_avatar_proxy/v4/letter/v/cdc98d/32.png) [@Vancity](https://community.start9.com/u/Vancity)
#### Post date: [September 29, 2025, 6:54pm UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/9 "2025-09-29T18:54:33Z")

</div>

This worked for me also thank you.  
I still have this other issue where I can’t open the page for mempool or datum gateway. It says this site can’t be reached. I actually had this fixed at one point and pages were working I had to ssh into my system again and start the process from scratch because my miners were not connecting…now that everything is connecting and all good I have this problem of site can’t be reached. Any help would be appreciative!

---

<div class="post-metadata">

### Author: ![Vancity](https://community.start9.com/letter_avatar_proxy/v4/letter/v/cdc98d/32.png) [@Vancity](https://community.start9.com/u/Vancity)
#### Post date: [September 29, 2025, 7:01pm UTC](https://community.start9.com/t/error-log-initiating-electrs-service/1124/10 "2025-09-29T19:01:07Z")

</div>

Oh never mind sorry. I figured it out from this forum. Just installed bonjour and it is now working. Thanks !
