Allowing .local is no longer an option in Proton - Documentation update?

There used to be info on allowing .local addresses to bypass VPNs when trying to access the server on the Start9 Documentation / Common Issues / Troubleshooting. I somehow cant find that specific page anymore. Whatever the case, I have confirmed with Proton that this specific address designation is not an option. They keep sending me to split tunneling which can only address programs or IP addresses.
This is the same process for NordVPN, but I have found that this service is more glitchy when accessing my server.

Hey Stephen,

There typically isn’t a method of “allowing .locals” in a VPN app, but rather a blanket bypassing of the VPN for all LAN connections. That’s what you need to ask them about and is weird if they removed it for an app-specific setup.

What happens when you add your Server’s IP address? Does this allow all the .locals to work correctly?

Have you tried installing an alternative browser (i.e. even a variation of Firefox) and setting that in the app-specific way they suggest.

Maybe you should ask them about “bypassing of the VPN for all LAN connections” specifically, rather than .locals. It could be useful information.

I’ve reached out to them again and we will see what Proton says. I did not see any change in access by adding the servers IP address to the split tunneling. I still have issues with accessing the Start9 marketplace, updates etc.

Here’s the page in question in case we need a change - are you saying this option (Preferences → Connection → Allow LAN Connections) does not exist anymore? Let us know what they say. I am also curious if this is on all platforms, or perhaps was just never added to some.

I got a reply from Proton. Both my windows and android app do not have this blanket Allow LAN connection. It looks like certain IP ranges are generically allowed now. The reply from Proton is:

" While using our native application, all devices that are under the network range of - , - and - can be accessed within your local network.

Otherwise, it might be that your firewall is not properly configured. If that is the case, then please change your Firewall settings while being connected from Public/Unidentified to Home/Work network."

Thanks for the reply

Different issue but also maybe worthy of an update:
Nextcloud instructions on documentation and services instruction don’t align for http vs https. I think the needs to be updated to say you have to manually change the .onion address to https:// for android setup of nextcloud.

So Proton claims to support local networks by default. Can you verify you got this to work, or do you still have a problem with your network? I’ve fixed the nextcloud http refs in docs in a PR.

I’ve never had an issue getting to my eSO service and logging in. I can use services, notifications and system tabs all day long. I was playing around with every option I could find because I kept getting ‘request failed’ and other messages from Marketplace and Updates tab (add blocker etc). I like the hardware side of computers, not the software side so I’m still working on these issues.
My best experience with accessing Marketplace and Updates is with VPN off, on a cold re-boot of my windows machine and on the Onion browser going to the .onion site.

I’m a bit lost by this response. It sounds like you have a networking issue, and I’m not sure where to go without more insights about your network setup. It is best to start with the very basics, turn off anything custom, plug directly into router, etc. If you still have issues, you may need to start a new thread. Be sure to search for your problem first, others have solved similar networking issues.

I don’t see a settings for “allow LAN” but I have no problem connecting to my StartOS server via the .local address while ProtonVPN is enabled.

This sounds more like: :wink:

Might try:
Chrome, Firefox, or Edge for Windows:
Press Ctrl+F5 (If that doesn’t work, try Shift+F5 or Ctrl+Shift+R).

Chrome or Firefox for Mac:
Press Shift+Command+R.