Backup failed on Synology network folder


I hope everyone is doing well :slight_smile:

I just installed Start9 and want to backup my Start9 configuration to my Synology (beta DSM 7.2) and I have a fail during the backup creation :


I followed the instruction here and I can access (and create files) to the network folder from my Windows 11 computer without any issue after entering my account and password.

Tests I’ve done :

  • ping from Start9 device to my Synology : OK
  • creating files/folders into the network folder : OK

Do you any ideas ?

Thanks for your help! :pray:

I’m replying to myself :

I just checked the Kernel logs and found this :

023-03-28T21:08:59+02:00  CIFS: Attempting to mount \\\
2023-03-28T21:08:59+02:00  CIFS: VFS: BAD_NETWORK_NAME: \\\
2023-03-28T21:08:59+02:00  CIFS: VFS: cifs_mount failed w/return code = -2

I’m checking why I’ve BAD_NETWORK_NAME because I’m entering the Synology name into the " Hostname" field.

I tried to mount the folder manualy from SSH and it worked :

What I did :

nano /home/start9/.smbcredentials // entered my creds
mkdir /tmp/smb_test
sudo mount -t cifs -o rw,vers=3.0,credentials=/home/start9/.smbcredentials // /tmp/smb_test/
sudo -i
touch /tmp/smb_test/test.txt

I can now see the test.txt file created by accessing to the folder with my Windows PC.
And the Synology logs saw the connection from my Start9 device IP address :

Connexion 28/03/2023 21:34:14 XXX User [XXX] from [(] via [CIFS(SMB3)] accessed shared folder [Start9].

I tried with the Synology name but it failed :

root@wrinkly-swarm:~# mount -t cifs -o rw,vers=3.0,credentials=/home/start9/.smbcredentials //syn0/Start9 /tmp/smb_test/
mount error: could not resolve address for syn0: Unknown error

So I modified the /etc/hosts file to add the Syno IP address :       localhost
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters               embassy           syn0

Now the command mount is working and I succeed to create :

root@wrinkly-swarm:~# mount -t cifs -o rw,vers=3.0,credentials=/home/start9/.smbcredentials //syn0/Start9 /tmp/smb_test/
root@wrinkly-swarm:~# touch /tmp/smb_test/test2.txt

But the backup create still displays an error when clicking on “connect”

Do you have enough space for backup?

1 Like

What hostname are you entering into Embassy? It looks like for you it ought to be syn0 - you can try with .local at the end, but this should not be necessary.

If you’re following the guide accurately then it will work - if you have deviated from that, then something may be incorrect.


Make it work !

Hostname : syn0
Path : Start9
Username : XXX
Password : XXX

The path was not \\syn0\Start9 but only Start9… thanks for your answers ! :slight_smile:

1 Like

That would have been the next suspect - glad you got it up and running!

If our guide can be more clear, suggestions are welcome