Bitcoin Core 26.0.0 on Server One

While I had all the apps in the green field, I updated Bitcoin Core to version 26.0.0, which was done quickly. After the update Bitcoin Core app is asking to configure something, but I don’t know what :person_shrugging:t4: I did a restart of both the internet router and the server and everything remains the same, that is, requesting configuration. Obviously Bitcoin Core dependent apps are trying to access Bitcoin Core but everything dependently is practically stopped (in exclamation mark).
I don’t think it is delaying because it is updating something in the background that we can’t see.

In the Bitcoin Core app menu, in Actions tab, there are three possible actions to follow, each with different instructions in their respective descriptions:
Delete Peer List, Delete Transaction Index and Reindex Blockchain, even Uninstall.

The notification message the system displays indicates the following:

Accessing via Tor, which also worked before, is now giving me this message:

Any suggestions please? What do I need to configure? I have realised not to configure anything at all, until I can follow instructions here. I would like to please know serious routes from experts in the field, using Server One.

Thank you in advance for following my thread.

I’m wondering if it will be good to stop Core Lightning, Lightning Terminal, LND, BTCPay Server, electrs, Mempool so Bitcoin Core app 26.0.0 can reset itself.
What do you think? Please I need an answer from someone with experience.

If someone can please explain to me precisely, what happens if, despite the warning: “Services that depend on LND and electrs will no longer work properly and may crash”, I stop the app? Is there really any risk?
I hope a good hero in this community with the skills to help a desperate rookie can respond asap. It’s been almost eight hours since I trusted the update and there is still no response.

You may have what’s now considered to be an unallowed character in your Bitcoin RPC password. Inspect that if you can.

The Bitcoin service thinks you need to hit Config > Save. That will re-write the config file for bitcoin to the container’s disk, so go ahead and hit it even if you change nothing.

You can stop any service you like at any time. At worst, dependent services will continually crash and be restarted until their dependency is turned back on and functional again.

If you are still having problems after that, please show a little of your Bitcoin Log (you can DM me if you like).

And actually, there does seem to be an issue with LND and/or CLN after that, you may have to go to Config > Save for those two services as well:

1 Like

Thank you for responding @George
Let’s solve this please.
According to me, I have the same information since I purchased the device. How is it possible that something has changed at the RPC Password?

The Bitcoin password policy changed, last release, actually - but doesn’t seem to have resulted in this bug until this latest release: 26.0. To be clear, these were not changes to Bitcoin Core itself, but to the bitcoind-startos wrapper that we use to package Bitcoin Core.

This actually appears to be also be an issue with electrs and mempool now too. For Bitcoin and each dependent service, please go to Config > Save. If Bitcoin Core wants you to change the RPC password to disallow any specific characters, please do so.

This seems to have solved the issue .…:exploding_head::sweat: and are the moments when I admire this kind of system and the competent community, especially you @George. Very grateful for your support :handshake::people_hugging:.