Bitcoin Core sync keeps timing out (stuck at 99.60%)

I have been downloading BTC core for about a week and it was running pretty smoothly until it got to about 90%+ downloaded. It is now timing out continuously and is not downloading at any real speed (5-20 kpbs) when it restarts to download. I’ve tried restarting, shutting down, as well as a system rebuild but nothing seems to work. I also checked that it wasn’t the internet connection with the device by downloading other services and they all do at normal speeds.

I built the device and it contains a 8GB RaspberryPi and a 2 TB HDD (basically all the recommended specs on your guide).

Any help would be appreciated and please let me know if you need additional info.

Keep in mind that we HIGHLY recommend AGAINST spinning disks. Our guides explicitly recommend SSDs and it is very likely that you will have problems with an HDD. I would not be surprised if this is the cause of your issue.

Other possible factors are power delivery (20w power supply is recommended), and data connection (disk to pi). HDDs in particular will also require their own power, and again, we recommend abandoning them entirely.

I made a typo, it is a SSD but is external. I’ll take a look at the power supply but never was an issue with my other node. If it were that wouldn’t all the services run into an issue and not just bitcoin core??

Bitcoin Core is one of the heavier services, especially for disk operations. Although they often work fine, the Pi is unfortunately not really built for this, which is why we are moving away from them (especially with external disks). The best experience will come from using an all-in-one style case that provides a power management board, but ultimately you will always be relying on a USB connection for all software operations, in addition to storage. This may be exacerbated by our system in some way, but we understand that most projects suffer from these i/o problems, and we are seeing a trend away from this hardware as a result.

Regarding your issue more specifically - are there any errors in the Bitcoin logs? Also where do you have your RPC Threads and Worker Queue set? You might like to raise those values to 16 and 128 and see if it helps.

Thanks, Dave. Appreciate the quick responses. Those are the values set and don’t see any errors in the logs. BC will just time out and then continue to get a few blocks before doing it again. It worked perfectly fine up until the last 10% so at this point I’ll just have to get it fully synced and see if it resolves itself.

When it times out, is this just the healthcheck reporting? Meaning, there are no issues in the logs, but the healthcheck goes yellow with the timeout message? If so, this is a known bug in our healthcheck, and nothing is actually wrong with Bitcoin. How long has it been stuck at 99.6? You may just need to wait for it to complete

Below is the only thing I see in the logs that is abnormal

2023-06-22T13:46:50-04:00 2023-06-22T17:46:50Z Socks5() connect to mixflxcyqoe43lkfbcaupk4psefl3otzpotnqt237unl4omi4ywbqayd.onion:8333 failed: host unreachable

This is what it shows on the UI dashboard

It is slowly going up, so I agree, I’ll just wait and see if it fully syncs and then hopefully it doesn’t have the same issues.

That just means that this particular peer was not available.

Yes, these healthchecks are very helpful, but can sometimes display inaccurate information. We have fixes in place for version 0.4.0 of StartOS.

Let me know what happens once synced.

Finally got synced and it seems to be staying connected. Downloading electrum server now, so I’ll follow up with you if I run into time out issues when using Sparrow with it. Thanks again for your help and good to know about the health checks.

1 Like