Bitcoin Core Update Issue

I updated Bitcoin Core to 26.0.0 today and now Bitcoin Proxy is displaying a warning.

Seems minor but wanted some input please.

You’ll need to uninstall Bitcoin Proxy… it hasn’t been needed or supported for a long time.

Once removed, you can update and use everything else as needed.

Huh? First indication of a problem I’ve seen. Thank you.

Server One on my side is also having troubles after updating to Bitcoin Core 26.0.0.

What are the “troubles?”

1 Like

Not sure but seems like uninstalling Bitcoin Proxy may have created another problem regarding the Tor connection. Is this possible? What was it used for? Sorry for the silly questions but I haven’t really thought about this in quite some time and can’t remember. I am asking because I checked the log file and noticed the connection is continuously failing now or at least I assume it is a recent occurance (ie. ‘Socks5 () connect to w7lfdjldkjf…onion:8333 failed: host unreachable’). Thanks.

No, that is not related. Proxy’s feature set was made obsolete by Bitcoin v25. You probably need to reset tor or bounce the server.

Tried to reset tor twice but it did not solve the problem. Could you point me to instructions on how to bounce the server b/c I don’t know how to do this? Thank you so much.

System → Restart (at the bottom) - keep in mind that the log that you posted means that your node tried to reach another tor node that was not available. This does not indicate that you have a tor problem. I should have mentioned this. If you can reach your device via .onion address - it’s on the tor network.

So I can reach my device via .onion but it is using the ‘http’ protocol seen here…

…is this something I should concern myself with?

This just means that you can and should use https instead now if you’re set up to use Tor on a standard browser. If you have a bookmark, just edit it.