Bitcoind backup fails with GPG error

I’m getting an error during backup for bitcoind. All my other services are backing up with no issue. The backup is going to a USB drive, if that matters. I don’t know if it’s related, but I also can’t seem to open a lightning channel to the Start9 HQ node anymore. I get “Funding Failed Due To Internal Error” and that’s definitely a new thing.

Here’s the error message on the backup:

Failed: Backup Error: Could not create backup: duplicity error: GPGError: GPG Failed, see log below: ===== Begin GnuPG log ===== gpg: decrypt_message failed: Unknown system error ===== End GnuPG log =====

Any ideas?

I suggest starting with Bitcoin service and verifying it is running properly. Status Running and health checks have a green check mark. Also, download the OS logs and look for "INFO mount_package_backup :bind " One of those entries should be for bitcoind. See if there are any error messages in that area.

Health check is all green. Backup says completed while everything is running. The error shows in the notifications at the end.

I don’t have an error for bitcoind, but I do have this:

WARN list : startos::disk::util: Could not collect usage information: mount: /media/embassy/tmp/—removed by me in case it’s sensitive—: unknown filesystem type ‘LVM2_member’.

And this:

ERROR startos::manager::manager_container: The service electrs has crashed with the following exit code: 1

Those are the only things I see that aren’t INFO or DEBUG.

Hi there!

Hmm, it seems like your Bitcoin data has become corrupted. This can occur, for example, during a power outage. To confirm, you would need to search through the Bitcoin logs for errors like this:

Corrupted block database detected.
Please restart with -reindex or -reindex-chainstate to recover.
Corrupted block database detected.
Please restart with -reindex or -reindex-chainstate to recover.
Aborted block database rebuild. Exiting.

If you find it you can try to use bitcoin action to reindex the blockchain. Be aware that Reindexing the blockchain in Bitcoin Core involves rebuilding the blockchain database from scratch. This process revalidates and reindexes all blocks and transactions in the blockchain, ensuring that the database is consistent and up-to-date.

Bitcoin > Actions > Reindex Blockchain

This could be related to fail backup and problems with LN functiong properly.
Please let us know of Your findings.

I don’t see that error anywhere in the logs, but we have been through some extended power outages where I wasn’t able to shut things down properly.

Just to add some more info, I’m seeing this in the electrs logs:

WARN electrs::mempool] mempool sync failed: batch getrawtransaction request failed: transport error: Couldn’t connect to host: Resource temporarily unavailable (os error 11)

I see that error when my bitcoin node isn’t available - for example I see it in electrs log at the time that the bitcoin backup was starting.

Also worth adding…

The repeated errors don’t look good at all. It looks like many of the services you have are running into corruption issues. This may even be causing the backup error as the backup process is being tripped up by the corruption.

But I also had a theory that perhaps the previous backups you’ve made have been corrupted too, for the same reasons.

I think these would be worth a try:

  1. Move the backups you currently have to a safe location and try making fresh backups from scratch.
  2. Try a system rebuild to attempt to fix the issues with the binaries, then try 1) again.

Okay, just finished doing all that. I removed my USB backup drive, copied the backup folder to another PC, and formatted the backup drive again. I tried a system rebuild yesterday, also, but still couldn’t get a backup completed without the error.

Side note - the exFAT format doesn’t work for me on Linux using “Disks” or CLI. I have to format on a Windows PC for some reason.

As of right now, the backup is complete with no warnings, so your suggestion fixed it. Thanks!!