Error "no suitable video mode found. Booting in blind mode" EmbassyOS on Asus desktop

Howdy everyone, I am working on setting up Embassy OS on gaming PC I’ve got. I’ve checked and double-checked the USB but it still will continue to say “no suitable video mode found” when I try to boot. The visuals do not boot past this.

System Specs

TUF Gaming X570-Plus (wi-fi) Bios Ver. 2607
AMD Ryzen 3 3200G wit hRadeon Vega graphics
2*G-Skill 8192MB 2133MHz (16GB RAM total)
Sometimes an Nvidia GTX 745 (I believe. I can’t remember exactly)

Suspected Issue

Embassy OS does not detect and/or use the internal graphics built into the Ryzen Chip.

Issue in detail and attempted troubleshooting.

I first tried it out without the externa GPU and just the internal graphics. I tested the PC with Garuda Linux in this mode and it worked fine. Embassy OS boots until it just shows “error: no suitable video mode found. Booting in blind mode.” This is where it gets stuck. If I leave it on that screen it will eventually sound the beeps of embassy OS, letting me know that it has booted into the USB and is ready. However, no changes in the visual.
I have retried this by switching from the mobo HDMI to the mobo DP, no changes.
I have tried booting the the nomodset mode (not sure what that exactly is), no changes.
I have tried making various changes to the BIOS with no luck.
Such as: changing PCIE Video to IGFX Video, Changing the UMA fram buffer sized from auto to 1G, enabling/disabling IGFX mutli-monitor, Disabling/enabling CSM, making sure Secure boot is disabled, enabling/disabling fastboot.
I didn’t do those super methodically so I may have missed something.

The point at which I made a bit of progress was when I stumbled upon this github issue page error: no suitable video mode found. Booting in blind mode · Issue #238 · sebanc/brunch · GitHub
I tried both the commands contained at the very end (insmod all_video, insmod gfxterm).
This got me past the initial “error: no suitable video mode found. Booting in blind mode.” and put me on this page.

Perhaps that will help.

Now is where I finally made some progress. I plugged back in the dedicated nvidia GPU and plugged into that instead of the MOBO. Once I did that I was able to boot into Embassy OS and install it. After I was able to install it I was able to boot into eOS fine.
Unfortunately, due to logistics of fitting in all the drives that I need to for my server, the GPU will get in the way.

So two questions:

  1. How do I (or is it possible) to get Embassy OS to recognize my the Ryzen Processor internal integrated graphics. (Maybe it is the issue where Embassy doesn’t have proprietary blobs? I thought Ryzen stuff doesn’t need drivers?)?
  2. Is it possible to install Embassy with the dedicated GPU, take out the dedicated GPU and have no GPU? Is that possible for a server? Do servers need graphics processors?

Thanks for any help that anyone can give.

Welcome and thank you for the detailed report. You are correct in #1 that this is most likely that your system requires some additional driver packages, if you knew what they were we could add them to this list for consideration as an optional addition at boot.

In regard to #2, you do not need graphics at all, and even during your error, your server was online at http://embassy.local, where you can do both install and initial setup. Following this you can continue to access from any client using LAN or Tor access, or client applications. The OS is designed first and foremost to be headless, so there is no need for a monitor, keyboard, mouse, etc either - you can tuck your server into a convenient corner - all it needs is ethernet and power!

Ok, thanks. That makes sense. Also, I am fine with running it in headless mode, so this will work out for me well. I currently run my yunohost server headless so It won’t be a big switch.
How would I go about finding the proper drivers that I need? I’m assuming it would be the linux drivers for that specific Ryzen Chip, but where would I locate that? Is there isn’t a helpful linux driver’s support page unfortunately. Any resources that would be good?

1 Like

I don’t have any resources on this, sorry. You’ll just have to search around. If you have a graphics card, that is likely where to start looking, but if you aren’t using one, then yeah - it’s the embedded graphics. In general, AMD provide open source drivers much more readily than intel/nvidia.