Error when connecting by https

Hi all,

I went through the connect through LAN guide and I am getting ERR_SSL_PROTOCOL_ERROR when connecting by https LAN. I am using a DIY embassy with an old x86 laptop as the hardware. I have tried on both a mac and windows machine to access through https and both aren’t working. All computers I have tried connecting with are on the same network as embassy. I can connect by Tor and http, but https is failing.

When connecting by Chrome or Brave browser I see ERR_SSL_PROTOCOL_ERROR

When testing in terminal using curl -v

I see :

*   Trying
* Connected to ( port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*  CAfile: /etc/ssl/cert.pem
*  CApath: none
* (304) (OUT), TLS handshake, Client hello (1):
* error:1404B419:SSL routines:ST_CONNECT:tlsv1 alert access denied
* Closing connection 0
curl: (35) error:1404B419:SSL routines:ST_CONNECT:tlsv1 alert access denied

Any idea what I am missing here?


The IP address should not be used except for troubleshooting. Please use your embassy-unique-id.local for LAN connections. You can follow these guides to set up your LAN certificate. Please let us know if you have issues after following the guides.

Seems like it was an issue with my router DNS server. I was able to set it to auto and my issue was resolved. Thanks!

1 Like