Firefox SearXNG Default Search Engine

Attempting to get SearXNG working as the default search engine on Firefox using the top address bar and not having to bring up the webpage itself. However, every time I search it queries the .local address vs the .onion. Not a big deal when on the lan, but if traveling and I still want to use the embassy service as primary I’d like to not have to bring up the .onion page to initiate a search.

Minor inconvenience, I know…but still seems like something that’s probably a small setting somewhere that I’m overlooking.


At this time, you would need to set the .onion address specifically. One thing you can do is add 2 separate instances, one for at home (LAN) and one for on-the-go (tor). Here are our guides if you haven’t seen them yet:

Hopefully this answers your question. We will be adding much more networking flexibility in the near future - stay tuned!

1 Like

Thanks Dave!

The problem wasn’t necessarily setting it up as the default search engine, but rather it reverting to .local instead of .onion every time a search is attempted when simply typing something in the search bar up top to search, as opposed to navigating to the .onion page itself and then typing it in. If that makes sense? I’ve tried deleting it as an engine option and connecting again, same result.

I’ll keep messing around with settings and see if I can find the culprit.

Understood. I think we’d need to understand your setup in particular to understand this issue. When you followed the guide - the UI that you opened (LAN or tor) would be what decided where your default searches are directed. Is this making sense? Or are you saying that your searches actually go to both onion and local, just not when and how you want? If it’s the latter, that would be very strange to me.

Let me know

Sorry, should’ve clarified that a bit.

I go to the .onion address for the service, which loads fine, no issues. I right click from there to add it as a search engine, then go into settings and make it the default. From there on, when I search it instead tries to use the .local address instead, which is odd because I’ve never used it? I’ve also tried not setting it as the default, but as just an option, and when I select it from the menu instead of the default the same result. So for some reason it seems to be trying to just use .local regardless?

I’ve never heard of this and I’m not sure how Firefox would even know the .local exists without you inputting it. There must be something else going on here. If you want to hop into our livechat on, maybe you could share some screenshots of your configuration.