Gateway Timeout after update

I just let me Start 9 node update itself, and now I get a Gateway Timeout when I try to login. I have no clue what I should do to try to get past this. Basically, it’s the first issue I’ve had. I’m running on an x86 with 16gb ram, 2tb ssd. Any suggestions?

UPDATE: So, a couple of things… For some reason it turns out my VPN software, which used to not affect local connections, is now a problem when I connect to local nodes (not limited to my Start9, also affects my Umbrel). So that’s one issues solved.

Second, my iPhone continued to show “invalid gateway” when I attempted to login to my Start9. But now I see it’s only using Safari on my phone, I can get around it using Chrome on my phone - but have to ignore the “your connection is not private” warning, due to an apparent issue with my SSL certificate… Not a big deal.

So, I guess I figured out my issues and I’m unsure if either are related to the Start OS update or not. But totally open to any input.

After upgrading to v0.3.5, your server will take longer to shutdown and then longer to start up that a regular reboot.

The most likely scenario is that you have the login screen open and cached in your browser but it’s not currently connected to anything. But by the time you read this, it long since will be able to connect, but…

Before you try again do:

  • Windows: Ctrl + F5
  • macOS: Command + Shift + R
  • Linux: Ctrl + F5

And it should work.

Thanks for your response! You seemed to type it exactly as I was updating my post… I actually got past my issues with some notes on my issues.

OK, I see those.

I think you’d benefit from sitting down and running through the initial guides again, because it would seem you didn’t fully complete them last time.

If you start right at the very beginning, you’ll see it even mentions VPNs.

…and though you might need to skip steps you have done, try to repeat as much as possible.

Then we can work on any specific issues that remain.

Well, the odd part was that my VPN software never affected local connections to either of my nodes. This VPN worked w/o issue for a year with my Umbrel, and a few weeks with my Start9. But then suddenly, both my local nodes were affected by the VPN - so I can only think something changed with the way the VPN software allows LAN traffic (I’ve not found any setting related to LANs with this VPN). And then, I guess coincidentally, the Safari/iPhone connection (no VPN running) started having issues with just my Start9 node, locally, right after the update. But now, since I’ve gotten past both issues, no further support needed. Thanks for your help!

Can I ask what VPN software this is?

Nord… And I see there’s an update, let’s see if it changes anything… Nope.

It sounds like Nord has a whitelisting feature. I’m a bit shocked that such a popular VPN provider has not integrated a LAN Networking toggle in their app’s UI. Have you looked thoroughly through the settings to be sure there’s not an option like this? It may be called ‘Local Network Sharing’ or similar.

I’ve spent a ton of time combing through the app and a fair bit of time Googling and not found any answers. And I just googled a whitelist for NordVPN and fell short of easy answers (EDIT: and now I see perhaps there might be some ways to whitelist that would require a fair bit of additional figuring out of stuff). If it was important to me I’d spend more time on it, but it’s just not a big deal to me. I have to disable my VPN once in awhile to access some websites, etc., so it’s not a big deal to disable it when I access my nodes. It was really just an issue when I hadn’t realized the local network access changed after a year using Nord.