HELP with Embassy Pro

I can not update to the new version for my Embassy Pro. I can not get the correct Root Certificate. I can not get to market place it constantly is doing a search for services. I can not get to registries Start 9 or Community as it keeps reading but says request failed failed. Can any one help me?

Also this has been going on for months but I just have not had time to get help.

You seem to be having a few separate issues.

It’s important that you follow the guides during initial setup so that later things are easier to resolve if anything goes wrong.

Root Certificate
I’d be interested to know what your exact error is. Did you go through the process of trusting the root certificate at all?

This is something you’d do on your client computer. Setting it up means you’re able to access your unique adjective-noun.local server address, as well as the individual service UIs securely with no warnings.

But even if you don’t set it up, you can force your way through, which I assume you have done, as you’re having problems with the StartOS UI.

Connectivity Issues
It’s nearly impossible for us to guess as to why your server is unable to access the internet in an uninterrupted way.

We’d generally recommend you hard refresh the browser window to make sure it’s not a caching issue Ctrl + Shift + R, Cmd + Shift + R (on mac).

You could also try restarting each link in the chain… server, router, client.

One of these would normally get things to work properly.

Ive had the Embassy for a year and a half. I hadn’t gone on in a few months and when I went on last fall I had issues that I had never had before. I was working with Okin but he had too leave for some personal business and It never got resolved. He said there was an update to the Start 9 OS and I didn’t do it. He tried to get me to do a fix for it from Github. I tried but wasn’t sure what to do. I have gone to the manual 1000 times and followed to the T like I did original set up which worked fine. Here is a screen shot of the warning. Also my clock on the Embassy does not match my computer.

Yes my UI’s don’t work for my apps I have like Matrix, Syncthing, Vaultwarden and File Browser

If OKIN was directing you to Github, he was likely putting you through the flashing guide to get you set up with the latest StartOS version in spite of your networking/internet issues.

Whether those networking issues are related to StartOS (possible, but unlikely) or with your network connection (more likely) having the latest StartOS wouldn’t be a terrible first step/fresh slate to begin troubleshooting from.

This is the flashing guide:

And the first step does indeed involve downloading StartOS from GitHub. You’d flash it to a spare USB stick, insert it, power down your machine, power up, and follow the guide.

You’d be sure to choose to use the Existing Drive (to maintain all your existing data), and continue from there.

Once complete, we can look at your networking issues. That your server can’t connect to the outside world now… either the registries or the to fetch the current time indicates an issue with your router or broader networking setup.

He was having me do a Hot Fix. I can get into my server. The apps are working and check good. I can’t access the UI’s. When I put files into my folder on my client computer it is going over to my server using Syncthing.

Here are some screen shots of what I am seeing.

My Embassy won’t let me sign in using HTTPS:// but will using HTTP:

When doing the flashing, do I put the flash drive into my Embassy Pro or my client computer?

I just flashed onto my flash drive. Stuck in SS flash slot and turned on

From your new messages, it looks like you have no problem with your server other than the issues I asked about in my initial message.

  1. You did not trust your Root CA.
  2. You can network issues that you need to resolve unrelated to your server.

Neither of these requires flashing anything, but should you want to flash (its fine to do so as an alternative to updating the OS via the UI), then I have to point out that you are not reading the links I’m sending. I can tell because you are asking questions directly answered in the step by step guides themselves if you were to follow them.

If you don’t read or follow the guides, or if you rush through them too quickly… especially with something as serious as flashing the whole OS… you’re going to make mistakes and cause new more serious problems.

To start to resolve your networking issues only…

Try these steps:

In particular, hard refresh your browser, check your internet connectivity, restart your router and server and if you’re on Windows, reinstall Bonjour.

You have 2-3 separate networking issues at the same time, plus you haven’t gone through a few of the initial setup stages. While some of the specific checks in the links above won’t be directly relevant to you, others will, so go through them anyway.

Also, since the forum isn’t a live chat, I can’t follow what you’re doing with multiple messages. If you need help in real time, the best place to ask would be in our Telegram group, here: Telegram: Contact @start9_labs

I read the instructions and followed them. I went to my router and it is allowing LAN. Now it won’t let me sign in. I stuck the flash drive into the Embassy in the SS slot and it seemed to be working. I went to http:Start.local. I went through that set up. I read the instructions several times for each step to make sure I did them correctly. I have not rebooted my router but the instructions didn’t say to. I will try that. Other than that I guess I am toast. I guess I’ll have a $1400 paper weight!

If you do flash the device, which you can do at any time without a problem, you’ll have seen the stage in the guides where it explains how you’d retain your existing data with Recover and Use Existing Drive. This is in the guide.

But, even if you do that, you get a new password (you’ll have typed it in, this is in the guide) and a new unique address for the StartOS UI.

As part of this process, the flow will have you download the the Root CA, set that up and log in. The file you download will tell you what your unique .local address is.

Because you probably a new IP etc, you may still need to HARD REFRESH your browser, clear the cache or use a different browser to be able to see the new login screen. It will not work to log into the new screen.

It’s difficult to get into a situation where you’d brick your machine and have a “paper weight”, you’d have to venture quite far outside the guides for that, you simply have repeated caching issues.

I saw the picture diagrams and when done it wend to select a drive again but gave me no choice.

I’m not sure what diagrams you are referring to, but you won’t need to “select a drive again” unless you’re going through a flashing process for a second time. Once you’ve installed StartOS the first time, you can remove the USB stick and use your device as normal. The installation flow ends with you being told to remove the USB and to restart.

This is where I am at. What should I choose?

It Says Recover? That’s what I am going with

Now it says I have Clock Synch Failure. Go to docs. I went to docs. Very short paragraph.

As per the previous instructions I’ve left for, you’d select Recover to maintain your data.

Regarding Clock Sync Failure, this is related to your lack of being able to access the internet. I assume you’ve completed the entire process and now have an up to date StartOS.

If so, you’re next issue is working out why your server can’t reach the internet. I’ve provided two links for that with a number of points.