Install on beelink mini12s to USB fails

So I have a brand new Beelink mini12s (16gb ram, 500gb nvme) and an external 1TB SSD. I made a boot USB using the non-free iso and chose the 1TB ssd drive to install to. I am using the external because the nvme is too small to run a Bitcoin node and startos doesn’t support adding/recognizing additional drives.

It starts to install then errors out. See attached image

This error specifically indicates that the installation media that the installer attempted to uncompress and copy files from from is having issues. I suggest you try flashing to a different USB drive.

Have you tried installing on the internal drive first to see if its an issue with the flash? Internal drives are super cheap now so I’d recommend just buying a 1tb nvme, formatting it and putting it into your machine.

this is brand new 128GB high endurance microSD i just used to install startOS on a raspberry pi4 that worked without any issues. I just reflashed it to the x86 image since the beelink finally got here.

I will try again then find another microSD. Will let you know how it goes

well no luck. I have 3 other microSD that fail to format. Only one that will format is the high endurance one. I tried both non-free and regular iso but once I selected the 1TB ssd i get this error

Might just bite bullet and get a 2TB nvme…

Are you sure its the right iso. You should use


If this is indeed the correct ISO, consider inserting the disk into another computer. Then, format the external 1TB SSD using a disk utility or wipe it clean using a command in the terminal. You need to first, use the lsblk command-line utility to determine the correct volume and run:

sudo wipefs -a -f /dev/<your drive>

This command-line tool is specifically designed for erasing filesystem signatures and other information on a storage device. Now try again to install StatOS.
Saying that It might not be the best idea to rely on an external drive due to potential connectivity issues and slower disk speeds. Consider upgrading to an internal NVMe 2TB SSD for improved performance and reliability.

1 Like

Thanks, I went ahead and bought a 2TB nvme and should be here in two days. The external was not ideal I know but I was cheaping out and trying to use existing hardware. I will save that drive for when startOS supports adding more drives if i need to expand later.

1 Like

Still no luck. It sees the new 2TB drive but still won’t install. same error as before. I ried 3 other sd cards and 2 other microSD to USB dongles and same error everytime.

I am using balena on a windows11 machine to flash the non free iso.

I figured it out…

  1. Make sure to use an actual usb drive and not a microSD in a USB
  2. In order to boot from USB to install, i needed to put the boot mode to LEGACY
  3. Installed startOS and reboot
  4. Go into BIOS and re-set boot mode back to UEFI

Success after that!

Now newest issue is no wifi interface is available so need to figure out how to get that working again but I’ll dig around

1 Like

I don’t have any experience with this DIY. Maybe some community members will chime in. But a few basics you can check:

Secure Boot: Ensure that Secure Boot is disabled. StartOS might not boot if Secure Boot is enabled because the OS bootloader might not be recognized as a trusted source.

Observe Boot Process: Pay close attention to any error messages that appear during the boot process. These can provide clues about what might be going wrong. If you see specific error codes or messages, jot them down.

Firmware Update: Check if there’s a firmware update available for your Beelink Mini12s. Sometimes, firmware updates can resolve compatibility issues with operating systems and hardware.

Trial and Error: If none of the above steps work, you might experiment with different BIOS settings, such as toggling AHCI mode, other storage options, or even graphics settings that might be affecting the boot process.