Jelly Fin Stuck on starting

Hi everyone,
I’ve recently installed JellyFin and had it working before. But now it’s stuck on starting in the services menu.
Has anyone encountered this before and could you recommend some troubleshooting.


Are other services stuck in starting as well? If so, then a system rebuild would fix this.

If not, then we’d have to investigate the service logs, to gather more info.

Hi other services are working with no problem. I’ll do a system rebuild!

I’ve done a system rebuild - the service is still stuck in ‘starting’. The logs for JellyFish are empty.
I can post system logs though.

Seems you misunderstood my instruction a bit. If other services are fine then you don’t need to do the system rebuild, only if they were also in Starting.

Just to confirm, currently the only service that is stuck in Starting is Jellyfin even after a system rebuild?

Have you tried a Hard Refresh of your browser? Just to eliminate a potential caching issue?

Hold down the Ctrl key and press F5.
Alternatively, you can also use Ctrl+Shift+R to perform a hard refresh.

Mac OS X:
You can use Command+Shift+R to perform a hard refresh.

Hold down the Ctrl key and press F5.
Alternatively, you can use Ctrl+Shift+R to perform a hard refresh.

Do your OS Logs have anything that jumps out at you as unusual, or any visible errors you find there?

To get to them go to SystemInsightsOS Logs

Oh hi - yes I misunderstood. To confirm all other services are working except for jellyfin. I’m reinstalling it to see if that fixes it.

Yes the OS logs do look odd:

Since you are already doing a reinstall let us know if that changes anything. Are you on the latest version of StartOs & of Jellyfin?

Just want to make sure to eliminate those as factors.

Hi the reinstall fixed it, although I wish I hadn’t because it would have been interesting to troubleshoot the issue.
Since it was a new install I didn’t have any config that was important to me.

1 Like

Yes, the troubleshooting is always educational & beneficail in that regard, but at least now you’re up & running.

Glad to hear you can now enjoy your server further.