LND service installed and synced. Rebooted and now get PR_END_OF_FILE_ERROR error

Hi all,

A few days ago I setup a fresh start9 server. Downloaded bitcoin core and synced. Then installed electrs and waited for it to sync. Then installed mempool. All good and minor hiccups. Today I installed LND and it did the sync. I decided to reboot and now I can’t load the start9.local page. I also tried the IP address with the same result. I get the following error in Firefox (I’ve tried multiple browsers and can’t get access either):

Secure Connection Failed

An error occurred during a connection to start9.local. PR_END_OF_FILE_ERROR


The server is still working though, I can still access the mempool.local url which at least is a good sign.

I tried removing the start9.local.crt certificate and reapplying it, same result.

Any idea what happened or how this can be fixed? Could it have something to do with the LND service? If so, is it possible to stop the service via SSH?

Any help is appreciated, thanks!

I SSH’d into the server and went to embassy-cli to try to troubleshoot (or rebuild). All commands generate the following error.

embassy-cli server restart
General error: HTTP Error: error sending request for url (http://localhost/rpc/v1): error trying to connect: tcp connect error: Connection refused (os error 111)

Is the localhost in http://localhost/rpc/v1 supposed to be the server name (start9.local)? If so, how to best correct this? Not much I can do to control the server at the moment.

Update: Did a hard reset (just pushed the power button) and rebooted that way and now I do have access back to the local server page. Phew!

All services came back up. LND took a few minutes to do a sync but now says it’s up and running.

For now it looks like everything is resolved thankfully.

1 Like

Glad you sorted out that these errors are all insinuating connection problems!

1 Like