Marketplace is Missing Bitcoin Proxy upon upgrade to 0.3.4~3

On upgrade to Start9 0.3.4~3 even after a few restarts Bitcoin Proxy is missing from Marketplace even though I’ve had it previously installed. Just for clarification, it is still installed on the server and running, just missing from the Marketplace tab and from here: Start9 Registry

Is this normal?

Bitcoin Proxy was removed from registry. With Bitcoind it is no longer requierd. You just have to point your services to bitcoin core in config tab and it should work.

As H0mer alluded to, all the features of Proxy have been added to Bitcoin Core, so we deprecated Proxy.

Thank you @H0mer and @start9dave . Can anyone point me to the instructions on how to add a custom user per service that I attach to Bitcoin Core. I don’t see any location in Bitcoin Core’s settings to add a different user per different service like Proxy had. That was the whole reason I was using Proxy. As it stands Bitcoin Core only has one user (default was bitcoin) for usage for services.

I’m obviously missing something and just need to be pointed in the right direction.

Thank you for your time. I love the S9 product and it’s principles/idea.

It is possible to create a new user authorization in the Bitcoin service. You just have to follow these steps: Go to Config → RPC settings → Advanced → Authorization and add an RPC Auth configuration string. Here is a link to a website that can generate one for you. I would advise you to use it offline for security reasons. Let us know how it went.

1 Like

Thank you, @H0mer. That is exactly what I needed.

Auto-configuration using RPC Auth will be re-introduced to the Bitcoin stack in a future update. No ETA at this time, but you can use it manually until then as indicated by @H0mer