Mempool/Jam .local address not working?

After successfully installing the Mempool and Jam app… Clicking on the Launch UI button takes me to a new web browser tab that states ’ This site can’t be reached? BTW my .local name for Start9 Home works ‘Market Place’, ‘System’, “Connected” green check at bottom etc… Also the Tor addresses for Mempool and Jam work fine. Is this a DNS issue?

I have uninstalled and reinstalled Bonjour multiple times using the guide… via System Settings > Remove Programs.

Please help thank you!

The first thing to always try when unable to reach .local is a hard refersh and/or clear the browser cache

Chrome, Firefox, or Edge for Windows:
Press Ctrl+F5 (If that doesn’t work, try Shift+F5 or Ctrl+Shift+R).

Chrome or Firefox for Mac:
Press Shift+Command+R.

1 Like

Thank you for the reply but I already tried all clearing cache and different browsers, no luck.

The steps you already took to connect via Tor and un/reinstall Bonjour were the right ones from a troubleshooting perspective. This could be an MDNS issue on your client device – It is very common with Windows machines. Service .locals are MDNS “aliases”, whereas the main UI is an MDNS primary. For some reason, Windows and sometimes other devices just hate aliases. This is something that the team is working on obsoleting in upcoming releases of StartOS.

Have you tried accessing your Mempool and Jam .locals from another device (e.g., phone/laptop)? That could be a helpful next step to better isolate the issue to the original client device. Let us know.

1 Like

Hi Jeremy,

Thanks for the reply I will try another device that was next on my list. I can ping and nslookup the adjective-noun.local domain no issues. It’s just the Jam and Mempool .locals so I believe you are correct. Also no issues with other .local domain I have setup.


Ok I installed the cert on my iPhone 15 iOS 17.4 and same issue? Start 9 main works fine so does services page, etc as seen in screen shot (removed the adjective-noun from screenshot) . So I figured maybe Mempool had an error installing did an uninstall/reinstall same issue?

I also run MyNode in https and Mempool works fine using the alias although they use a simple URL with just the port number. Also running mutiple Synolgy NAS’s on the network using aliases never have an issue reaching them.

I’m currently out of ideas, lol

What is the browser error on the iOS device?

Have you done a reboot of StartOS? Have you checked the OS logs? Any errors?

Hi Dave,

Same as PC can’t open page because the server can’t be found. I looked at the Mempool logs and nothing jumped out at me… I can post them if you wish?

OS logs, not Mempool logs. I’m guessing you’ve already tried a reboot of the server?

1 Like

OS logs are just full of:
2024-02-07T15:20:01-05:00 2024-02-07T20:20:01.641868Z DEBUG run_main:check: startos::manager::health: Checking health of bitcoind

2024-02-07T15:20:11-05:00 2024-02-07T20:20:11.659132Z DEBUG run_main:check: startos::manager::health: Checking health of mempool

2024-02-07T15:20:13-05:00 2024-02-07T20:20:13.916584Z DEBUG run_main:check: startos::manager::health: Checking health of electrs

2024-02-07T15:20:17-05:00 2024-02-07T20:20:17.454027Z DEBUG run_main:check: startos::manager::health: Checking health of bitcoind

Yes I have rebooted many times, lol.

I finally got this working so I thought I would report back so it helpfully helps someone else. I use a Ubiquiti UDM-SE for my home network. My node is running in a separate VLAN from my PC. You also must obviously create some firewall rules but that was not the issue. The issue was I had to enable Multicast DNS in both VLANS for it to work.

Thanks for the reply’s everyone!

Perfect, and thank you for the response back letting us know the solution. Glad you got it working properly!

1 Like