Mempool Never Synchronizes... related to Bitcoin Core error?

When I launch the Mempool UI, it just looks like it’s loading. “Backend is synchronizing 99%”
Under health checks, the transaction indexer says, “curl (6) Could not resolve host: bitcoind.embassy curl. Initial blockchain download still in progress. Mempool will not display correctly until this is complete”

I’m guessing it’s related to the fact that Bitcoin Core as well as Electrs, seem to switch on and off from starting to running and back and fourth again. It’s been running for weeks and I’m sure the blockchain is downloaded.

I’ve tried restarting the server one.

Thanks for any help!

If Bitcoin Core and Electrs seem to be in a starting loop. The recommended fix is doing a System Rebuild.

This action will tear down all service containers and rebuild them from scratch. No data will be deleted. This action is useful if your system gets into a bad state, and it should only be performed if you are experiencing general performance or reliability issues. It may take up to 72 minutes to complete. During this time, you will lose all connectivity to your server.

This option can be found under System → Power → System Rebuild

Hmm. Thanks.
I did that twice and it’s still showing the loading symbol and goes from starting… to running back and forth for Bitcoin Core, electrs and Mempool.

You need to work out where the issue is. Is it with Bitcoin+Electrs, or it is with Mempool?

The error in the health checks of Mempool says that Bitcoin isn’t working. So what do the health checks of Bitcoin say? Is Bitcoin stopping and starting? What are the logs of Bitcoin saying? More errors?

If Bitcoin and Electrs are stable and green, constantly and continuously, we can work on Mempool.

Here’s some of the service logs. Since Bitcoin Core is starting, I’m guessing we should start there? It says Status starting, then Status Running every 10 seconds or so. Should I uninstall Bitcoin Core and install it again?

Here’s from the Bitcoin Core logs:
2024-05-26T21:20:27+00:00 Please restart with -reindex or -reindex-chainstate to recover.
2024-05-26T21:20:27+00:00 : You need to rebuild the database using -reindex to go back to unpruned mode. This will redownload the entire blockchain.
2024-05-26T21:20:27+00:00 Please restart with -reindex or -reindex-chainstate to recover.
2024-05-26T21:20:27+00:00 2024-05-26T21:20:27Z Aborted block database rebuild. Exiting.
2024-05-26T21:20:27+00:00 2024-05-26T21:20:27Z Shutdown: In progress…
2024-05-26T21:20:27+00:00 2024-05-26T21:20:27Z scheduler thread exit
2024-05-26T21:20:27+00:00 2024-05-26T21:20:27Z Flushed fee estimates to fee_estimates.dat.
2024-05-26T21:20:27+00:00 2024-05-26T21:20:27Z Shutdown: done

Here’s from Electrs:

2024-05-26T21:29:40+00:00 Error: electrs failed
2024-05-26T21:29:40+00:00 Caused by:
2024-05-26T21:29:40+00:00 0: bitcoind RPC polling failed
2024-05-26T21:29:40+00:00 1: daemon not available
2024-05-26T21:29:40+00:00 2: JSON-RPC error: transport error: Couldn’t connect to host: Connection refused (os error 111)
2024-05-26T21:29:56+00:00 Error: Failed to resolve address bitcoind.embassy:8332: failed to lookup address information: Name or service not known
2024-05-26T21:30:11+00:00 Error: Failed to resolve address bitcoind.embassy:8332: failed to lookup address information: Name or service not known

Here’s from Mempool: 2024-05-26T21:31:12+00:00 May 26 21:31:12 [329] ERR: Electrum error: {“errno”:-3008,“code”:“ENOTFOUND”,“syscall”:“getaddrinfo”,“hostname”:“electrs.embassy”}
2024-05-26T21:31:12+00:00 May 26 21:31:12 [329] INFO: Disconnected from Electrum Server at electrs.embassy:50001

From the logs you shared, Mempool / Electrs errors are both likely due to Bitcoin Errors. Uninstalling and Re-installing Bitcoin should resolve this. With a server one and a reasonable internet connection redownloading the blockchain should complete in no more than a day or two at worst. There may be other options, but this is the most simple.

Thanks for the suggestion. Bitcoin Core and Electrs both needed to be uninstalled and reinstalled. Both are stable and running now.

Mempool still wasn’t working so I tried to uninstall it. Under Status says “removing…:” in red for many hours now. An error popped up saying that it couldn’t be removed. I can’t delete it and I can’t install a new version from the services tab. Hmm.Maybe a sytem rebuild now?

I suggest doing a simple server restart first. If that doesn’t clear it, you should do the system rebuild.

NOTE: If you do a system rebuild, be patient. It will take some time for the rebuild to complete. The system will give you an estimate on the amount of time required…