My Start 9 registry and community registry states request failed. Cert is expired

It had been a while since I went into my Embassy Pro. I went in and it said my certificate was not valid. I tried to update but it was the same certificate that I currently had. Also my Registries state request failed for Start 9 and Community. Please help

Hi. Can you please provide some additional information so we can better assist. How long is quite a while? What exactly are you accessing when you get the certificate was not valid error?

I assume you have access to your server as you state that you are able to see that Registries state request failed. If so, then could you please go to SystemInsightsAbout and tell us what Version of StartOS you are currently running?

Hi Okin,
I haven’t been on in about 6 months. I can get onto the server and have my current services are running. When I go into Market Place no other apps show up. It is constantly searching. When I go into Updates is states under Start 9 Registry and Community Registry “Request Failed” in red. I can not download any additional apps. When I try to do something I get a paragraph in red that starts with Error

Error

RPC ERROR: Network Error error sending request for url (https://registry.start9.com//eos/v0/latest?server-id=8c850363-aeca-4d74-ab1a-a2eb3f1d7698&eos-version=0.3.4&arch=x86_64): error trying to connect: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:ssl/statem/statem_clnt.c:1919: (certificate has expired)

Okin,
I also just deleted my Certificate and reinstalled. Followed directions from Documentation under macOS for reinstall.

What StartOS version does it give you when you go to SystemInsightsAbout?

Okin,

My Embassy is Version 0.3.4

There was a hotfix which came out in August and should have you on version 0.3.4~4. Could you try updating to the latest version of StartOS with the hotfix as this might solve your problem → Release v0.3.4.4-hotfix · Start9Labs/start-os · GitHub

However, you could wait till after trying again with your reinstalled Certificate. But you should still do the update afterwards.

I did and the same issue is happening with reinstalled Cert. I will use your link and update
PS I am a boomer so be patient! LOL

1 Like

Before you use the link, since you are using a Pure. Can you try updating by going to SystemSoftware Update?

No worries at all, we are here to help.

Will do, Trying System Software Update

Got the same error message that I copied and pasted on first answer to your inquiry

Have you tried restarting your server yet? Let’s give that a try and then see if it allow for you to do the update via the method I shared above.

So go to Power under Systems and click on restart?

Restart in Process. It says it will take a while? Not sure what time frame we are talking about.

1 Like

Correct. If it doesn’t want to allow that then you’ll have to do a hard restart (unplug power and plug back in).

It should be fine. Let it run till it’s done fully restarting, then log back into your server as per usual and try the update again. Please do let us know how it goes

Says connecting in YELLOW

Thank you very much. Ill let you know as soon as it finishes

My pleasure. I might be away when you get back but someone else from the team will likely answer before my next shift.