Nextcloud Calendar for iOS not syncing

Hi folks,

I meticulously followed the Start9 documentation here for Nextcloud calendar however, I get an error when going to the Calendar app, showing that Calendar is not syncing.

  1. I made sure my Nextcloud is configured properly (I can see all my files on the WebUI and on the app on my iPhone)

  2. I made sure to follow the guide to enable the Calendar feature on the webUI [it was already enabled]

  3. side note: I successfully synced the Contacts on my NC to my iPhone following this guide: Start9 | Nextcloud Contacts

  4. Trying to do the same thing for my Calendar, I followed this guide [I installed both the standalone client already, as well as followed the device integration]: Start9 | Nextcloud - iOS

  5. Here are the error I got:

5a. I restarted this process multiple times, same error: “Unable to update calendars”
[To see this screenshot, navigate to Calendar app > Hit Calendars at the bottom]

I had the same trouble with my iPhone the first time. I then went to settings → Calendar → Accounts (you have already added a CALDAV account) → your nextcloud account. add username: embassy and your password. After a failed attempt you should see and advanced settings at the bottom (which for some reason is not there by default). under advanced settings turn on SSL, enter port 443, and https://yoururl.onion/remote/php/dav/principals/users/embassy/

Give that a try and I’d be curious to know if it works for you

So, I tried using that specific url you’ve mentioned and it gave me 2 weird screens (attached) and then “unable to connect.” Which IIRC is a different error from the beginning.

One thing I’ve noticed Plato g around using that new url you gave me, is that the Settings revert back if not saved “properly” after making changes in Calendar > Accounts > Advanced Settings. After saving there it couldn’t connect and automatically asked me “Do you want to try without SSL?” to which I said no and it asked me if I wanted to save my config although it may not connect which I did.

So yeah giving you a bit of context there.