Nextcloud Recognize needs to download AI models

Hey everyone, I’m trying to set up nextcloud memories. When I go in to the app, it shows that I need to download the AI models.

How do I go about downloading them? Do I need to?
I know the OCC command, but how do I go about executing this command. Isn’t nextcloud in a container? Can I just SSH in and run the OCC command?

I happen to use this myself, but was never presented with this that I can remember. I use Memories to date-order my photos in a timeline like Google Photos. I don’t use it for face recognition, which I think this is for from the feature list.

That said, I don’t see any configuration options in Memories app settings, and there’s not mention of the feature in the app documentation.

If you move beyond this confirmation message, do you have anything related to this in the Settings for Memories? For other features, such as geo-location, they provide handy GUI options to downloading bits and pieces.

From what I can see you’re supposed to have both Recognize and Face Recognition installed separately, and this this message is from those.


Yes, you need to manually add libraries (pdlib & bz2). When done, it should be possible to install Face Recognition app from the GUI.

If it doesn’t work, they mention that it can also be manually downloaded, installed and configured. In our case, inside a container, and adapted for it.

Installation · matiasdelellis/facerecognition Wiki · GitHub

If you’re just getting this up and running, it might be worth a go. Perhaps less so if you have an important library of photos you don’t want to risk.

Yep, I got this error when I tried to install face recognition “App “Face Recognition” cannot be installed because the following dependencies are not fulfilled: The library pdlib is not available. The library bz2 is not available.”

How do I access it via SSH? Also, I would prefer to just disable the GUI via the keyboard attached to the server (ctr+alt-F2). However, when I do so, I don’t know the username and password to log in? I tried root, start9, embassy, admin + my password and non of them worked.

Hey there - this is well outside the scope of what we support. Any changes you make via SSH are generally not respected by the OS, and may cause problems. At this point your options are to hack together a new .s9pk or otherwise run Nextcloud separately on another server. I am currently working on a big Nextcloud update (including the latest upstream v27), and I intend to include functionality for several popular apps, such as Memories, Face Recognition, and others. There’s no ETA at this time, but if you want to run this on StartOS without issues, my recommendation would be to wait for the update.


Got it, thanks! I will definitely wait for this instead of breaking something myself. Are you referring to Hub 4?

27 is the Nextcloud server version. Hub refers to a suite of basic tools, which I will be integrating as best I can under the current architecture. For apps like Talk (Jitsi video conferencing), StartOS v040 will be required. Hub 5 is the version that is available as of v27.