None of the installed services are accessible on the LAN by their .local addresses on windows 10


As the title says except that the embassys own .local address works fine and on a separate ubuntu desktop system everything is ok. So this really seems like a windows only issue. Anyone encountered this?

Please post general usage problems in the Troubleshooting section (I’m moving this thread there), and also search the forum to make sure your question has not already been answered (it has):

1 Like

Thanks for the info, looking through again the start9 guide and installing Bonjour did indeed solved this problem.

And sorry about the incorrect post, it was my bad. I’m a little rusty with posting on forums :slight_smile:

1 Like

No worries, glad you’re up and running!

Bonjour has been a big pain and steps are underway to eliminate it as a dependency for Windows users. Look for this in an upcoming update.

Even with Bonjour installed I get “Gateway timeout” errors often when connecting form a Windows laptop via local LAN and htts. When I look into the server itself everyhing runs fine.
Also the pop-ups in the settings menu of apps always hang via https . I added the url of the server to the excude list for ad-blocking etc in my browsers, it does not help. I tried chrome and brave.
It is just a pain having to walk up to the server itself all the time to configure stuff.
I do hope this can be fixed soon :pleading_face:

It sounds like you probably have to follow the guide to reinstall Bonjour. Have you tried from another machine (ideally not Windows)? That is a good test to be sure it is in fact a Windows issue.

I did as you suggested with Bonjour. It did not seem to change anything. Then I looked up documentation for installing BTC core and LND and saw suggestions of forwarding ports (BTC code: 8333 and LND 10009, 9735) on the router. After I did that all is fine, even configuration menus and pop up work as they should (they never did).
Are there any negatives to forwaring thes ports? I did not see any mention of it in the Start9 texts or the fora.

This should not be necessary and is not recommended. If this truly solved your problem (and not something else, like a device reboot for example), then you may have a networking / tor issue in addition. This would be much faster to diagnose in instant message. Please reach out to the Livechat at the bottom of our homepage. Techs are available during most Mountain timezone daylight hours.

Hi Dave,

I tested and removed the port setting and did a reboot on my external machine and nothing changed; everything works as it should. You are right, it is not necessary. Thanks for helping.

1 Like

My pleasure. If nothing else, this was a good exercise, the knowledge of which may assist you with advanced features / hacks in the future. We have a lot in store for 2024! Happy Hosting…