Onchain Balance mismatch

Hi ,

So I started the node.
Transfered 3 million sats onchain.
Open an channel (3 million) with start9 node.
Channel created successfully.
But Onchain is now still showing that i have 3 million available.
Is this a bug? My Umbrel with the same workflow shows 0 sats as onchain.

Am i missing anything?

If you moved the sats from onchain into a channel, the sats should be removed from the onchain balance. Not sure what’s going on here. Give it a little time. Double check the amount of sats you delegated when opening the channel

I will observe it for a bit. Thanks Rick.

Similar issue. I’ve opened two channels. Node shows online at Amboss, Thunderhub, Lightning Terminal and RTL. On chain balance is wrong. I couldn’t open channels. I think the balance issue is why.

The last major change I made was setting up a Watchtower with LightningNetwork Plus. I shut that down and restarted LND. It’s took longer than usual to sync to graph. The Log said it was rescanning addresses starting back at block 791211. Hope this finds the TX.

Next step is restore the backup?


I also had my watchtower setup. Will try to disable that and restart to see if that resolves the issue. I will circle around .

Mines taking a bit. I’m up to block 800,000 from 791211. So be patient or just wait for me to report back if it worked.

Block 810,000 8min ago.

Oh, I forgot. I think, turning of the Watchtower did nothing for me. My next step was: Goto ‘Actions’ in the LND service and “Restart Wallet Transactions”. That’s why it’s resyncing to graph. I’ll let you know just the same.

Sounds like you might be approaching a resolution with this. Please keep us posted for the visibility of others facing the same issue. I will just add since you made a reference to restoring Lightning from backup, that in general this should be avoided and only used as an emergency/last resort option. Doing so would force close all channels, which could take multiple days.


Curtis you are correct, disabling watchtower does nothing. Like you, I am trying the reset wallet transactions. LND is now syncing. Will report back.

That worked for me. All balances are correct.

Awesome! Me too. Confirm that this works. Thanks Curtis!

My next problem. Tried to open new channels. They failed because of minimum channel size. My balance is off again by the amount attempted. Will start a new thread for that.