Pending force close will never confirm

I have a channel that I tried to force close after the peer had been unreachable for weeks. However, the close fee was way to low (10 sat v/byte). I have no idea why the fee was set that low. Anyway, this transaction will probably never confirm.

I have tried a lncli bumpclosefee on the closing txid, but I am just told that the channel does not exist. I am probably doing something completely wrong and silly.

I have seen that you can use chantools for these cases, but it does not seem to be available on the StartOS.

This is the channel point:
7c653bd29faf7a6e941f64c25faace8d687544997e040cdcc5443a08f988530f:1
And this is the unconfirmed transaction ID
416988192c03510ce937c9b6fa1a77986885e61e09ffc5b94311016d373cf86e

What can I do? Any help appreciated.

This fee will have been set and reserved at the time of opening the channel, that’s why its not something you can set at the moment you decide to force close.

Your attempts to bumpclosefee on the txid probably failed because you were using the txid and not the channel point, the correct format is…

lncli wallet bumpclosefee --channel_point=<channel_point>

Offhand I’m not sure if you’d have problems running this if your closing TX has been purged from the mempool for the fee being too low… this might have happened if your mempool is set to 300MB. You might want to give LND a restart first to rebroadcast, then try.

1 Like

Thank you for pointing me in the right direction! Forceclose is now confirmed.

In case someone comes across this in the future, I cannot tell with 100% certainty what solved it in the end. But let me try to explain the steps I took.

I restarted LND, then I bumped the fee of the channel point with this command:
sudo podman exec -it lnd.embassy lncli --rpcserver=lnd.embassy wallet bumpclosefee --sat_per_vbyte 28 7c653bd29faf7a6e941f64c25faace8d687544997e040cdcc5443a08f988530f:1

Command was successful and the output said that the fee was bumped on two TXes. However, nothing happened with the channel. Still no confirmation in the mempool, not of the original transaction and not of the new child-pays-for-parent.

In the end I restarted the whole Start9 server. Then finally it was broadcasted and confirmed on the next block. I suspect it is not sufficient to restart LND, probably Bitcoin-core also needs a restart. But here I am only guessing.

I wish there was an easier way to perform this bumpfees on Start9. I guess this is a scenario that more people will encounter in a higher fee environment, especially with channels that were opened during low fee periods.

I also wish there was an easier way to change the size of the local mempool on Start9, than editing the bitcoin.conf

1 Like

You can edit the size of the mempool you wish you keep, and other settings, in Services → Bitcoin → Config → Advanced → Mempool

1 Like