Re-flash my Embassy OS (again) or wait (hoping the initialization will finish)?

Question: should I re-flash my Embassy OS (again) or wait (hoping the initialization will finish)?

  • I just updated (re-flashed) my Embassy OS (eos-0.3.3-92cd85b-20221206_raspberrypi.img) and powered it up with the un-altered 1TByte connected as normal.
  • Now the screen is stuck at “Initializing Embassy (Preparing data. This can take a while)”


  • Several months ago: Embassy upgrade failed.
  • Yesterday: re-flashed micro SD.
  • Yesterday: did not wipe or alter 1 TByte drive with blockchain.
  • Turned on raspberry pi with 1 TByte attached as normal.
  • Chose the option that corresponded to “keep my blockchain data; use same password so new Embassy OS image can still access that data” (my wording from memory; I did not screenshot).
  • Now been stuck for 24 hours at “Initializing Embassy (Preparing data. This can take a while)” screen.

Question: should I continue to wait for initialization to complete? What is the Embassy doing? I’m getting disk access LED flashing on the 1 TByte hard drive. Is the Embasssy verifying transactions and blocks? Or is it stuck and I’m waiting for nothing?

Any suggested paths for me to take? I appreciate any pointers on how I can discover if the delay is expected or unexpected.

Hi there and welcome!

Sounds like something has gone wrong, it could be a bad flash. I would start the process over. Did you verify the checksum and use balena etcher to flash?

Thank you start9dave for your response! Yes I did verify the checksum, and yes I used balena etcher. Since I did see and briefly interact with a gui it seemed the flash was successful.

Shortly after powering on the raspberry pi (with freshly flashed micro SD) but not the first screen, a page showed up called “Recovery Options” and the middle of 3 choices was “Use an existing, valid Embassy data drive (not a backup)”. I chose that and then picked the drive (there was only one choice for the drive) then set the password to the same password that was used on my Embassy before I reflashed the micro SD. I’ve been waiting for the initialization to complete for about 30 hours now. I’ve never seen the “SETUP COMPLETE!” screen that I see in your user manual.

The address of the screen that I see “Initializing Embassy …” is http://embassy.local/#/loading. Maybe the Embassy is waiting to be contacted at a new address?

If you think that is the wrong behavior for the Embassy , I’ll try power cycling the raspberry pi and try to continue. If that does not work I’ll try re-flashing the micro SD, but since I am getting the correct checksum it’s hard to grasp how that could be the problem.

Let me know if you have any other ideas. Thank you start9dave!

Unless you have a ton of data and your Embassy is currently making noises from its speaker, then definitely unplug it and try again. Also, what OS version were you coming from?

If you have further trouble after retrying, please email us at and we can set up a quick call to investigate and assist.

The address of the 30-hour screen is http://embassy.local/#/loading.

I tried also to load https://embassy-12345678.local/ (using the address at which I used to connect, not the 12345678 address) and there was no response.

I’ll try the power cycle thing and reflash thing then send an email like you suggested if that does not help.

Thank you,

Did we get this solved via email? Just going through old threads to make sure everyone is up and running