Registry, updates and .local adress not working

I have had trouble setting up my embassy for a few days now.
I am running debian with Firefox ESR on my client computer.
I have followed the guides and got a confirmation that the Root CA is trusted.
I can connect via local IP and https, but not using the noun-adjective.local.
Marketplace and updates will not load.
The bar is green and says “Connected”

I have done a Ctrl+Shift+R and cleared the cache
I have disabled adblocker
I have disabled VPN
I have done the firefox step for linux
I have restarted the computer
I have restarted my embassy
I have the latest version

Any help is much appreciated. If you need any more information, please let me know.


If everything is set up correctly by following our documentation as it appears to be according to your message. The next recommendation would be to restart your router and try again.


Can you run command in terminal on your Debian client:

sudo systemctl status avahi-daemon.service

This is to check if your avahi demon is working and mDNS addresses can be resolved.

If the status in not Active/Enabled then run:

sudo systemctl start avahi-deamon.service

sudo systemctl enable avahi-deamon.service

This action should resolve the issue with resolving your mDNS host address and service aliases. However, it’s possible that the problem could also be related to your router. Restarting your router might solve the connection issue. There also could just be a firewall type setting that is blocking “multicast” or mDNS. Please Let us know if you have any progress.

Thank you for that! This immediately solved the .local issue.
Followed up with a new router restart which solved the marketplace not loading issue.

What a great support you offer!