Ride the Lightning (RTL) Error 500 - Connect Econnrefused 172.18.0.41:8080

I am having a problem getting RTL to see my LND node. LND is running and it says it is synced. Thank you for your help.

Hi.

Just a few questions so we can get some clarity on what might be happening:

  1. Are your Health Checks for RTL Green?
  2. Are there any errors that you are seeing in the logs of either LND or RTL that indicate a problem?

Thank you for your help. A little background, it seemed to be working until I changed the node alias. That is when I started getting the error. I uninstalled both LND and RTL and then reinstalled them. That did not help.

LND has a green check and says: ‘Success : Synced to chain and graph’.

RTS also shows a green check and says: 'Success : RTL is ready to visit in a web browser '.
At the top of the dashboard, it says ‘Error! Please check the server connection.’

The last log entry is: ‘[5/20/2024, 12:24:54 AM] ERROR: Wallet => List UTXOs Error: {“name”:“RequestError”,“message”:“Error: connect ECONNREFUSED 172.18.0.41:8080”,“cause”:{“errno”:-111,“code”:“ECONNREFUSED”,“syscall”:“connect”,“address”:“172.18.0.41”,“port”:8080},“error”:“Error: connect ECONNREFUSED 172.18.0.41:8080”,“options”:{“url”:“https://lnd.embassy:8080/v2/wallet/utxos?max_confs=1000000000",“rejectUnauthorized”:false,“json”:true,“headers”:{},“method”:“POST”,“qs”:{},“simple”:true,“resolveWithFullResponse”:false,"transform2xxOnly”:false}}’

Changing a node alias does not break LND or RTL. You have some other error that is behind this that uninstalling and reinstalling these two services is not going to fix.

I’d suggest first restarting your server, then checking whether you have the basics of RTL configured right, then clicking Save.

Thank you. I restarted. Then LND would not synch while RTL was trying to start. I reinstalled RTL and now it works. I’m not sure what the problem was.

I appreciate your help.

1 Like