Self installed startos failing to connect to localui

Installed on local NUC box. All seemed to go well. Installed many services. But when I click on localui for some of the services I get the “Hmm. We’re having trouble finding that site”
Is this not supported and I should RTFM or should this have worked (my assumption)?
Another problem may or may not be related. Vaultwarden is not letting me save any entries but its localui does open.

Did you follow the guide to trust the root CA on all your client devices Start9 | Trusting Your Root CA

It doesn’t make a whole lot of sense that some .locals open and others don’t. It should be all or nothing.

Rick’s suggestion of going through the guides, each step one by one makes sense, you may solve the problem without having to understand the cause.

You might also want to look at the Common Issues: Start9 | Common Issues

Other things to look at and tell us are…

  • What client OS you’re using…
  • What patterns you see regarding .locals that work and .locals that don’t (are you sure some work and some don’t, or do they all work at one time, and then all not work later?)
  • Whether the services that don’t work have green health statuses and whether the one’s that don’t work on .local are accessible by .onion.
1 Like

The problem only exists on the Start9 machine itself. When I did the setup steps on another existing machine in the same network all the .local onion addresses are working.

All the ones that didn’t work directly on the Start9 box had green health status. As the problem ONLY manifest on the box I am using for Start9 it is obviously running Linux. The other box everything worked on is running Linux as well (Fedora 39 to be specific).

As I have a working solution (use other machine) it isn’t as hot an issue for me at the moment. Thanks for the help and suggestions.

StartOS is designed to be used headless, as a server, not as a client machine. Kiosk mode (what we call adding a monitor and keyboard) is designed for quick last dash debugging when networking is severely incapacitated. It’s not designed for the casual browsing experience, but rather getting access to the main UI in emergencies.