Server One backup fails

I need some help getting backups working.

I have a new Server One with Bitcoin and Vaultwarden services running. Now that I have some data worth backing up, backups are my next task.

I’m trying to backup to a shared folder on my Linux laptop.

If I watch the backup running, it looks like both services say they are backed up successfully, and I see many files written to the shared folder.

But the overall backup fails, with this message:

Does anyone know how to fix this problem, or how to troubleshoot further?

Hi @Unseated7790, welcome to the community and sorry about the issue that you’re facing in completing your backup.

This I/O Error likely means something is not quite right in the configuration. The best thing to do would be the retrace all of the steps in the guide to the letter for your client operating system.

As well, we offer real-time support 12 hours a day, 7 days a week. If you’d like, you can ping me in Telegram @JeremyGo and we can walk through it together. I’ll be available for the next three hours this evening.

Hi, Jeremy. Thanks for the reply.

I’ve reviewed the guide for sharing a Linux network folder, and I believe everything is correct.

As I mentioned above, I do see that lots of files are written to the shared folder during the backup process. If there is something wrong with the samba configuration (which wouldn’t surprise me), I don’t think it is anything mentioned in the guide. I don’t see any step there that makes me think, “Hey, if I didn’t do this right, some things might work but not others.”

Thanks for the offer of Telegram support, but I’m not desperate or impatient enough (yet) to install an app on my phone and then give them my phone number just for this issue.

Totally understand. For future reference, we also host our own Matrix server.

It’s good that some files are being written to the network folder, but as mentioned just running through the process another time would be a good first step in troubleshooting.

Another potential next step would be to attempt to run your backup to an external drive to see if that goes through successfully without any errors.

We can also look into your system logs to get a more granular look at what might be going on under the hood.

We will be happy to continue supporting any/all of the above on this forum thread or in Matrix, as you prefer.

I’ve been over and over the guide, and I’m certain I’ve setup the shared folder correctly, at least as far as the instructions in the guide are concerned.

I don’t have any external drives laying around that I can use, but I might be able to try backing up to a different computer.

Here is a screenshot of the system logs during a backup.

FYI, I’ve also contacted Start9 support directly regarding this issue, so please let me know if continuing this thread is resulting in duplication of efforts.

I’ve never seen this particular issue before. It could be a permissions issue - does your user / samba user have read/write access to everything there? You could force that to be sure. If that doesn’t work, I would probably wipe the backup and start over from the top.

Regarding users & permissions:

The shared folder and all files and sub-folders are owned by my Linux user, which is the user I setup with samba. The owner has full read & write access to all of it. I assume that is as expected.

When you say “samba user”, I assume you mean the user I configured to use samba, rather than an actual user named “samba”?

I’m also not quite sure what you mean by “force that”. How would I do that?


I deleted everything in the shared folder and tried a fresh backup, with the same result.

I’m going to try a different computer and report back.

Well…backing up to a different computer was successful. The problem is, I don’t want to backup to this computer, I want to backup to my laptop.

The other computer is also running Linux Mint (21 vs 21.3 on the laptop).

To the best of my knowledge, I followed the exact same steps. Permissions look the same on both machines.

This is just kind of a wild guess, but both machines have encrypted home folders, which is where the share is located. The guide didn’t mention anything about this being a problem. But I think I recall a change in how home folder encryption is handled in a recent version of Linux Mint.

Turns out the change I was thinking of was in version 20 (so not different between my machines). The change was that logging out does not unmount the encrypted filesystem…which doesn’t seem relevant here anyway.

…but the issue still might have something to do with home folder encryption.

I created an unencrypted partition on my laptop, and a new shared folder there…and it worked.

This is closer to what I want, and it might be an acceptable workaround…but it would be really nice not to need a separate partition. And from what I can tell, there isn’t any known reason why that shouldn’t be possible.

OK…turns out I didn’t really need an entirely new partition. I was able to create a new folder under /home, and that also worked. (Only my /home/user folder is encrypted, not the entire partition.)

This is good enough for me. I’m still curious why it won’t work under /home/user, but I assume the Start9 devs have more important things to work on.

Thanks for the suggestions @Jeremy and @start9dave.