Server Pro device reboots randomly every few hours

My Start9 Server Pro reboots on its own several times a day. This used to happen fairly often months ago, but seemed to become less until recently. Then started again after recent software upgrades. It will just randomly make the “reboot noise”, so I will go look and sure enough it’s rebooting again. Not sure what to do about this. Tried plugging it into different outlets, all software is updated, etc.

Any ideas?

Welcome to the community forums. You’ve come to the right place to ask your questions!!!

You mention you recently upgraded the software, please confirm what version of the software you are currently running (latest is

Generally speaking StartOS does not reboot randomly. The times I’ve had my server reboot unexpectedly have been on power failures - once a circuit breaker tripped, and once a child tripped and pulled the plug out accidentally. My primary StartOS server is now on a UPS (and blocked away from kid traffic). I’ve also heard of DIY hardware having hardware failures that caused a reboot.

If it does not appear to be power related, you should look at the OS and Kernel log files. From the StartOS menu on the left go to System → Insights → OS Logs and System → Insights → Kernel Logs. If you see something obviously wrong there you can address it. If not, feel free to post what you see in the log immediately before and after the random reboot and we can help diagnose the issue.

It’s always been on UPS (tried 2 different ones in fact) and away from child danger.

I notice this seems to happen more often if I am routing transactions through LND. Not a lot mind you, but 15 transactions yesterday listed in RTL. It was rebooting every 2 hours or so yesterday. I set my Fee Policy to an extremely high number today and have had no traffic. It rebooted after 10 hours for the first time today. Not sure if this is just anecdotal or not though.

I tried checking the logs, but many of them wipe out records when it reboots so I can’t see anything unless I happen to have it open at the right time.

This was in the OS logs when it happened today.

2023-12-04T15:56:58-08:00 2023-12-04T23:56:58.807347Z ERROR startos::db: WebSocket Closed: Network Error: WebSocket protocol error: Connection reset without closing handshake
2023-12-04T15:56:58-08:00 2023-12-04T23:56:58.807366Z DEBUG startos::db: Error { source:
2023-12-04T15:56:58-08:00 0: WebSocket protocol error: Connection reset without closing handshake
2023-12-04T15:56:58-08:00 1: Connection reset without closing handshake
2023-12-04T15:56:58-08:00 Location:
2023-12-04T15:56:58-08:00 /rustc/cc66ad468955717ab92600c770da8c1601a4ff33/library/core/src/convert/
2023-12-04T15:56:58-08:00 ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ SPANTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
2023-12-04T15:56:58-08:00 0: startos::db::deal_with_messages
2023-12-04T15:56:58-08:00 at startos/src/db/
2023-12-04T15:56:58-08:00 1: startos::db::ws_handler
2023-12-04T15:56:58-08:00 at startos/src/db/
2023-12-04T15:56:58-08:00 Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
2023-12-04T15:56:58-08:00 Run with RUST_BACKTRACE=full to include source snippets., kind: Network, revision: None }

The error from this log is indicative of a bug that was fixed a couple versions ago, can you please confirm your current StartOS version? Does this happen if you are not on a UPS (plugged into the wall)? Anything in Kernel Logs?

I’m on 0.3.5~1. It goes in weird spirts where it does it several times within a few hours. Then hardly at all for 10 hours. Then the cycle repeats.

I’ve tried plugging it into a wall directly, using several different outlets, and it does not matter. Same thing keeps happening. I tried buying a different power adapter with the same general settings as the one that came with it and this also doesn’t help.

The problem with the logs usually is that when it reboots the logs get wiped. Is there a way to see old logs? I’ve tried leaving the logs pages open hoping to catch it happening. When I’ve done that it just loses connection and then a reboot wipes the page.

Any more ideas?

Unfortunately kernel logs do not persist at all across reboots. It is possible you have a short in the power supply, or at the power connection to the board. This would require an RMA, unfortunately. Can you email us to start that process (Contact | Start9)?