Specter Desktop won't connect to bitcoin core

Unable to connect to bitcoin core with Specter Desktop on Linux. Tried following Windows and Mac instructions because there appears to be no Linux instructions. If they exist, please point me to them. Basically I have setup a Lenovo laptop with Embassy OS and installed bitcoin core, bitcoin proxy and specter without issue. Then Installed Specter Desktop on MX Linux and used ‘Getting Started’ feature to set up Tor, then unchecked ‘auto detect’ and entered specter username, password, Tor address from Bitcoin Proxy properties and Port 8332 in ‘RPC Configuration’ form. This failed and I then proceeded to try numerous configurations without success.

Problem solved. Needed to configure specter desktop ‘preferences’ to ‘run specter remotely’. Paste the domain from specter (embassy) in ‘settings/usb devices’ in the text box provided. I needed to change the domain to ‘https://’ for this to finally work. Catastrophe averted.

1 Like

Sadly my specter problems are not behind me. I am now unable to get specter to detect a ledger device. Received an “internal error: ledger is not in either the bitcoin or bitcoin testnet app” message after testing. No idea what to make of that.
This may be a cable issue because from what I understand some cables are simple ‘pass through’ cables vs OTG cables but I don’t think so. I’ve tried 3 other cables and got the same result. I doubt none of them are OTG but I guess it’s possible. Seems more likely that it is something to do with ledger.

Do you have the Bitcoin app open on the Ledger?

Bingo. Seems it was me and not the ledger. I’m not surprised. Thank you again.

1 Like