SSH connection issues RPC error

Hello I was editing the Nginx conf file via a SSH connection and the connection was cut. When I tried to login I get this error. “Key_exchange_idenification: read: connection reset by peer connection rest by port 22” and when I attempt to login I get this error. “RPC ERROR: Database Error error communicating with database: No such file or directory (os error 2)” Not sure how to fix this.

Can you tell me more about what you mean by “cut?” Do you have a bunch of unsaved changes in the config file you were working on, that would be difficult to re-do?

Hello Mike thanks for the response. It is a mess I wanted to change something in the NGINX conf file so I had to root into the directory via Putty. My connection was cut off in the middle of working I did not make any changes just opened a file, so nothing was changed, but when I tried to log back in I got “Key_exchange_idenification: read: connection reset by peer connection rest by port 22” At the moment my IP address is not showing on my network after a reboot.

Hello Start9 community the problem was solved. I decided to Flash via USB and BalenaEtcher it was super simple. I did a recent backup so only lost a few days work. I advise everyone Backup often for that unexpected mishap. Thanks again Rexter for reaching out much appreciated.