Stable diffusion

I am trying to generate images but nothing is returned in tor browser. Does this service actually work :joy:? pressing the refresh on both available models also times out after half an hour :face_with_head_bandage:

I’ve used it before and it worked for me. Though IIRC I was connected local. I’ve been meaning to go back and try it some more. I’ll let you know what I find.

In general if images aren’t showing up you should start by looking at the logs for the service. Often that will tell you enough to troubleshoot the issue. Also, it would be useful for anyone trying to assist you if you could let folks know what hardware you are running, what version StartOS, what version Stable Diffusion and and probably even what settings you are using.

I had uninstalled stable diffusion, but I’m loading it back in now :slight_smile: More info soon!

OK. I reinstalled the latest Stable Diffusion (1.1.1~4) on my server pure (startos v0.3.5.1). I accessed it via a desktop browser (Win10, Chrome using the URL - crazyonionlikeaddress.local and it worked for me. Took a couple minutes for my prompt to generate an image. While it was executing I saw periodic messages in the Stable Diffusion log that looked like:

2023-12-17T20:43:45-05:00 Total progress: 70%|███████ | 14/20 [02:37<01:12, 12.05s/it]A

I then tried again with my TOR browser using same crazyonionlikeaddress.onion and that did NOT work. Looking at the logs server side, it never received the image request.

Digging further, I found a TOR browser setting: HTTPS-Only Mode In my TOR browser, that was set to enabled in all windows. When I changed it to: Don’t enable HTTPS-Only Mode it worked as expected.

really appreciate it. I never would have found that :partying_face:

1 Like

I couldn’t actually get this to work yet with tor browser :face_exhaling: but am using it on local network :cook:

The only thing in my logs after model loaded is:
DATE Running on local URL:
DATE To create a public link, set share=True in launch().

Do I need to do anything else? The setting was changed in tor browser for all windows and I restarted. Also it seems I have all the same versions and machine as you.

What does “not working” entail? Do you have a browser error? Is the screen blank? This definitely works on Tor Browser - just tested good for me.