Start OS Docker error on old laptop

I was running start OS on an old sony vaio. It worked ok for a few months while sometimes taking some time syncing core. The last time I did a restart, this error appeared.
Have you guys seen this docker error before? What should I do? restart server or system rebuild options take me to the same error screen.

System Rebuild is typically what you want for docker errors. It will rebuild all the docker containers (while preserving your data). Sounds like that didn’t work though?

Did you recently do an update from an old version? If so, do you know what version? We’d like to reproduce this error if possible - there might be a bug in a migration.

If none of that works, probably the best approach is to reflash the OS to a fresh copy of the latest for which you can find instructions here (assuming your Vaio has an Intel or AMD cpu):

But if the last thing you did was an upgrade to get to this state, please let us know as it might require more care than simply flashing the latest and picking Recover > Use existing drive.

If you could also share the logs if there are any, it might give us more information


Thanks George and Dave for the support.

@start9dave the initial logs are attached.

@George Didn’t do a start os update recently. Only did some electrs, mempool updates. I tried Recover> Use existing data with the original version of the OS and received these:

and with the latest os:

This error specifically indicates that the installation media that the installer attempted to uncompress and copy files from from is having issues. Try flashing to a different USB thumb drive.

But as to the other errors, as I mentioned here, you probably want to use the latest release, not the “original version of the OS”. Please note that I changed the link in that post to the more specific x86_64 flashing guide.

Hi George,

I used another usb drive and the latest version of the OS and when asked to do to this:

I removed the usb and then pressed reboot and then surprise:

I forcefully rebooted the laptop and then the same docker error as above when I used the second latest version of the os:

It seems like you may have disk issues on this old laptop. Can you see if your manufacturer has a bios update available and try updating the bios? That may resolve these strange issues.

Did you actually choose Factory Reset here? Or Re-Install StartOS?

I tried re-install StartOS → use existing data on the disk in all the images from above. I tried to avoid factory reset or reinstall from a backup because I have a 1 month old backup :)) and in the meantime I added some things that I want to recover. This was stupid of me to not do a more recent backup…i know

Hi @George or @start9dave any other ideas before I do a Factory Reset?

I just solved this for another user, we had to flash a dev build and then ssh in and delete the docker temp directory. Can you hop into our livechat on and I can assist? If it is after hours, please use the contact form and I can get with you via email.

This is now resolved. Thank you very much for the help start9dave!

1 Like