Start9 on Dell 5420

Dell 5420
2tb nvme

I am receiving the unable to detect network on hardwired connection , not using wifi. I believe the issue is network drivers. I can see the link light flashing.
I have searched high and low on the forums but can’t find a solution. Is it possible the 5420 isn’t supported due to proprietary drivers?


When installing StartOS did you use the non-free.iso. This might make a difference if you didn’t

Yes I did use the non-free… I tried both with same results.

It’s possible, but not likely - most Dells run StartOS fine. What is your exact symptom or error?

I got it to work but only via a virtual box. Straight from Dell will not work as it will not detect network drivers.
I do wish not to use a virtual machine

Where is this error and what is the exact error, please?

As I stated the error comes in while loading start9os at the very end. Unable to detect network. This is in a wired connection on a fairly new laptop. Only way to get this to work was using a VM. I wasted too much time trying to get it to work without using a VM. I tried both ISOs. But once I started a virtual box I used the same ISOs without issues.
I am not going to redo my setup as I recently was able to get core to completely sync.
Wish someone would have replied days ago.

I’m sorry, this is not descriptive enough for me to understand. Can you take a screenshot? It doesn’t make much sense that a VM would work when the bare metal would not.

Our time for DIY troubleshooting is entirely donated, and the community often rely on each other for such issues. We are a small team and I’m sorry if our response time does not meet your standards for free community support. I think you’ll find it’s still better than most companies and projects.

I understand about the support being donated and I greatly appreciate it… I took about a week deciding whether to use Umbrel or Start9… After much thought Start9 won. I like to tinker but even that has its limits. I spent a good day trying to get start9os to work bare metal. I dont have a screenshot but it was definitely unable to recognize network card and this was verified when i logged on to the router. Router saw no entries from the MAC. Try as I may for the day no matter what i did, startos would NOT recognize the nic. so i tried the next best thing and virtualize it on the same laptop. used the same iso and voila, it worked… so bare metal did not work but i am glad i was well versed with virtual anything. Been working in IT for decades… I will gladly work for start9 on a PT basis.

Okay, well absent any more details it sounds like you’re at least up and running. I’ll consider this closed for now. If you ever try again and want to provide more info on the issue, please post it here. Welcome to the community