StartOS won't boot on an HP EliteDesk 8300

Hi, I have an hp elitedesk 8300 with core i5, 16GB ram and a 1TB SSD. Originally setup this machine for Umbrel and worked great even under debian 12.2. However I just heard about startos and want to try it on this computer, but after install the start OS with a flash drive and make the first boot, the screen just get a white flashing curson on a black screen, like if for some reason, it didn’t install any grub or bootloader.
To install the startos, I just downloaded from the github site, flash it with balena etcher and boot from the usb drive.
At first I got RCP error messages that was not able to open mkfs.vfat on sda drive; that problem was fixed flashing another usb drive with a live gparted os so I could erase all partitions on the ssd and create just one big partition on ex-fat.
I have tried several time this procedure and the StartOS flash seems to install the OS on my disk, but everysingle time I end up booting with a black screen with a white cursor.
I thougt maybe somehow my boot order was changed, but I enter on my bios setup and even the ssd disk is called Start.

What am I missing?

Thank you.


Hi Javier,

Which StartOS image did you download from Github? Non-free? That includes a bunch of proprietary drivers that can help DIY hardware get up and running. If you haven’t tried that, this would be your first step.

Next, it might just be the case that your particular setup is problematic… be it lack of driver for the graphics card, or a driver that doesn’t support the connected screen’s resolution… but this need not be a problem.

Unlike with Umbrel, a StartOS server is intended to be a proper server, and so isn’t necessarily supposed have keyboards and monitors plugged into it.

Instead of accessing the UI from the device itself with a monitor plugged in, unplug the monitor, reboot the server and try using the UI (the very same one) from another network connected device on your network → start.local → and continue from there. Without trying to load the UI locally (we call this kiosk mode) you should be able to get the device to boot fully and have it accessible over LAN.

Hello Stu.

I forgot to tell that the downloaded file was the non-free one.

The kiosk mode was an interisting idea, but how do I know that the server is working? I mean, right now I just unplugged the monitor and booted up the server again, but I don’t hear any sounds from the server. How do I know it is booting and working? in another networked computer, I selected start.local but just recieved: Unable to find page.

You could still be having problems for any number of reasons related to the hardware.

First, go into your router and see if you can see something new connected. If you can’t, but the ethernet port lights on your device and router are solid. If you can, at least you have the IP address and can try accessing with that.

One thing that sticks out in your original comment is that you see a mouse on the screen and nothing else when in Kiosk mode. If you are sure you’re booting the right OS, then this at least suggests you got past all the parts that should make your server accessible on the network.

I tried to used the kiosk mode on another computer, but my startOS computer simply doesn’t boot the OS

After several attempts I connected a monitor on the server just to realize the server thats the same (just a blank screen with a white blinking cursor).

Regretfully I had to go back to umbrel that seems to work fine on the same computer. I thought installing StartOS on the same computer my umbrel bitcoin node was running would be easier, but so far I couldn’t get it to work.

try disabling “secure boot” or something similar for HP in the bios.

Unfortunatelly, both the elitedesk 8200 and 8300 don’t have a secure boot option, so in a nutshell, StartOS should be very easy to install, although no my experience.

This should likely be straightforward, are you attempting to boot via UEFI or Legacy? Have you tried setting the BIOS to defaults and starting fresh?

The HP 8200 has only EFI and Legacy. Mine is booting on EFI. Should I try on Legacy?

Both are supported, but if one doesn’t work, try the other. You may also have to turn off Secure Boot.

I have tried with EFI and did not boot, I will try with Legacy. This computer model is old (about 2013) so Secure Boot is not available.

Well, another attempt to install StartOS on my computer, and another failure.

I removed the partitions, created one big partition on my 1TB SDD with exfat and tried to install StartOS. The process seems fine, until the time to boot when at the moment the computer try to access the ssd I just end up with the blank screen with a white blinking cursor.

I’ve tried booting on both EFI and Legacy and they do the same the same, seems to me like if the grub doesn’t install properly.

Blinking cursor means something tried to boot, then failed. If it gets that far and fails at that point, I can only imagine some compatibility issue with graphics. Reading back over our exchange, I’m not sure if you tried booting up without a monitor and seeing if the machine appears on the network. That way you might skip the error.

Hi, Stu…forgot to tell you: Since you told me about kiosk mode; I tried it but with no results. I waited for about 15 minutes and was not able to access the startos server from another computer connected in the same network. After that time, I turned on the monitor connected to the server and the server was as always. With a blank screen with a white blinking cursor.

This has to be an issue in the BIOS, unless you have a bad piece of kit. I would reset BIOS defaults, then try one at a time in Legacy and UEFI boot with and without secure boot (so 4 different tests). Be sure your Boot Order is correct as well, or it may never boot into the correct media.

Thanks for all your help, but after several attemps, I simply just gave up. I really thought it would be groundbreaking for me to replace Umbrel for StartOS.

Anyway, I just erased again the sdd, installed debian 12.2, installed umbrel and right now I am syncing again my bitcoin node.

StartOS is based on Debian 12; it makes no sense that this would boot differently. I’m sure this is fixable, but would require some more attempts. I get the feeling something simple is being missed. Did you reset your BIOS defaults? There’s also an outside chance that your drive is failing.