Subject: Inquiries about Blue Wallet Compatibility and Exporting xpub for Dual Watch-Only Wallets

Hello there,

I’ve a couple questions. First, is it true my blue wallet (watch only on Iphone) will not connect to the electrum server installed on my Start9?

If it does not, is there any problem exporting the same xpub to two different wallets, so that I have, in effect, two watch only wallets? I don’t see a problem there, but maybe I’m missing something.

Thanks in advance for your help

Here’s our guide for BlueWallet:

At the moment, though, iOS has broken Orbot. We don’t have a solution until a new Orbot comes out for iOS, which could be a while. Typically, when this happens (and it does, periodically), an Orbot fix is released shortly thereafter. It’s possible they just broke it for good, though, as currently, even a couple weeks later, there is still no fix for Orbot. Right now you should be able to get to most of your services web interface via “OnionBrowser”, but afaik right now there is still no solution for services like electrs in Wallets on iOS.

Thank you for the reply! So are you saying that no wallets on iOS can connect to electrum?

Correct, unfortunately(!) at this time, until Orbot finds a way around Apple’s latest sabotage.

If you want to reach electrs locally (only on lan, via .local), you can do this:
echo "/usr/bin/apt update && /usr/bin/apt install -y socat && socat tcp-l:50001,su=nobody,fork,reuseaddr tcp:electrs.embassy:50001 &" >> /media/embassy/config/
That executes a socat forwarder to the electrs container for inbound connections to your server on port 50001 at every boot of the server.

This will allow electrs from lan connections to your unique adjective-noun.local:50001

1 Like

Orbot for iOS seems to be working at the moment. I have a couple of watch only wallets on BlueWallet that are successfully connecting to electrs on my DIY Start9 box.

My Orbot on IOS still won’t connect. It has been broken for sometime and that seems to generally be the case for most. What version of IOS are you using?

17.2.1 is my current version

Cool. I guess you are just blessed and highly favored :slight_smile:

Did you change any of your settings. i.e. choose how to connect. I have direct connection, but I notice there are several options in the dropdown. Did you select something other than the default?

Just direct connected with no alterations to settings.