Trouble upgrading Rasberry Pi to Embassy Pro

Hi all,
I am trying to transfer my Start9 Raspberry Pi to Embassy Pro and ran into the following message:

RPC ERROR: Database Error migration 20230118185232 was previously applied but is missing in the resolved migrations.

Any thoughts or solutions greatly appreciated.

Did this error come up while following the steps in our Upgrade Your Raspberry Pi Guide?

Yes, everything seemed to be working step by step. It started the “setting up your server” and taking awhile, which was expected, so when I got home from work I saw the error message.

I restarted the Embassy Pro, and started the process over. It is copying data now, and progressing as it should, ticking off % copied.

Ok, so I went through the Transfer process again.

Initializing Embassy

Progress: 100%

Finalizing

Error

RPC ERROR: Database Error migration 20230118185232 was previously applied but is missing in the resolved migrations Restart Embassy to try again.

Not sure how to proceed. I have tried again to transfer
Thanks in advance.

I’m looking into this. What embassy pro do you have. Can you give me the specs?

Rick,
It is an Embassy Pro, purchased in November '22 during the pre-sale.
I cannot remember the specific specs, and I cannot find the specs in my confirmation emails.

We have flagged this for the senior techs and Devs. Not sure what’s going on here, but we will get back to you. Let us know if you figure something out on your end.

1 Like

Can you tell me what version of StartOS you are updating from and is your Pro flashed with the latest version of StartOS

The Raspberry Pi is running Embassy 0.3.5~1
Pro is running whatever it was shipped with. The only time is was fired up was to transfer data to it from the external drive that was connected to the Pi, and since that hasn’t worked transferring the data, I don’t know what version the Pro is running. Make sense?

I’ll let the Devs know and get back to you

1 Like

You can try to start the pro on its own and get it updated to the latest version before transferring it. If you haven’t ever started it up since '22 it will definitely not be on the latest version. If that doesn’t work you can flash the pro with the latest OS and then try the transfer. Here is the flashing guide Start9 | Flashing Guides

I will give it a shot and report back. Thanks.

1 Like

Flashed the firmware for Embassy Pro, and everything is up to date. I can now login successfully. Startup takes me to the login page. Not sure how to get to StartOS setup page to transfer data from Raspberry Pi.

Once you’ve got the latest version of the OS on both devices, you’ll be able to transfer the Pi data to the Pure/Pro… but there’s a catch. You already went through the setup!

You have to get into setup mode again. How? You’ll have to go through these processes here:

Creating a USB installer:
https://docs.start9.com/0.3.5.x/flashing-guides/os-x86

Doing the transfer:
https://docs.start9.com/0.3.5.x/misc-guides/transfer-data#flash-startos-and-transfer-data

It’s practically the same thing, it just doesn’t assume your turning on the Pure/Pro for the very first time, and you have to imitate the first time turning on process with the USB thumb drive/stick.

1 Like