Trying to install StartOS on Asus Z97 motherboard and blank 2TB Nvme disk fails

Hi, I am trying to install StartOS on an Asus x86 Z97 v3.1 machine that was running Windows 10 a few minutes ago. The board was from 6-10 years ago when the first Nvme M2 cards appeared on the mobo. This is a legacy boot machine, not a UEFI boot machine. My board has 1 Nvme slot and is “Crossfire Ready” (2 graphics slots). It has 4 cores and 8 threads. It was running Windows a few minutes ago, could reboot properly, and was hooked up to a KVM switch with a second windows machine.

I downloaded (the latest) StartOS non-free, thinking that would give me the maximum set of drivers and the most chances of success.
I downloaded and installed balenca, flashed a USB stick, and the flash was successful.
I swapped out the Windows Nvme for a formatted 2TB Nvme, and made sure the only other SSD disk (1TB Nvme) on a PCIe card was also empty.

First try was with the machine hooked up to the KVM switch. (No success)
Plugged in the USB, rebooted, the USB stick flashed as some data was read, then it locked on lit.

Second try was to connect the mouse, keyboard, and monitor directly to the machine.
Same results - the USB flashed with data activity, and then it hung in the lit state.
The data flashing light on the 1TB Nvme secondary disk also seems to be hung in the lit state.

Nothing shows up on the hardwired HDMI monitor - Not even the bios boot screen.
I removed the USB stick and still could not get anything to show on the monitor.
I cannot get into the BIOS with F2 or DEL. Strange.
(Mind you, I haven’t gone into the BIOS for years on this machine, so it might be operator error.)

I’m hoping someone here might have some ideas for me to try … (Thank you)


I removed the second 1TB disk to strip down the machine to simplify the possible causes of failure. I also switched the HDMI cable to the monitor for a DVI-D cable, and that allowed me to see the BIOS screen and boot from the USB stick. I have no idea why that worked and the HDMI cable would not work. Go figure. (UPDATE2: I added a KVM switch and reorganized all the cables to the server as part of the KVM setup. The server had been headless for a few days by this time. When I plugged in the HDMI cable to the KVM setup, the HDMI connection worked fine. The DVI-D connection was no longer required. I cannot explain it, but I am willing to believe that the highest-probability explanation is that I did something wrong in the initial setup.)

The StartOS appears to be installed correctly. In addition, I discovered that the “empty” 2TB Nvme was not empty! It had remnants of the Windows OS EFI boot partitions in there. So my theory is the machine was trying to boot from the wrecked “blank” Nvme stick, but couldn’t find a valid Windows partition. And I have no idea why the motherboard won’t drive the monitor over an HDMI cable. It worked fine for Windows. Go figure.

Anyway, I am moving on to the next step of the StartOS install. I am leaving this post here for the next person who might benefit from it.


Moved to the DIY topic, glad you managed to get online!