Unable to connect to .local embassy or service addresses on android (CalyxOS)


I’ve got StartOS up and running on my new embassy (Pi 4, 8gb, 1TB microSD). I can access the embassy .local address through both Firefox and Chrome browsers on my laptop. I can also access it via Tor Browser on both laptop and smartphone (Pixel 4 with CalyxOS). And I can it via IP address on Firefox Beta and Brave browsers on my smartphone. However, I cannot access the .local addresses (embassy or services) on either of those browsers on my smartphone - I get the same error, “This site can’t be reached”.

I have gone through all of the troubleshooting steps provided on the website, included clearing cache and restarting both browsers, restarting phone, restarting router, and restarting embassy.

Any advice on next steps will be appreciated - things have been flawless thus far until this!


Have you followed this guide?


Thank you for your response, yes I have. Am I correct in believing that my ability to access the embassy via from my smartphone browsers via it’s IP address is evidence that I have the root certificate added correctly?

Being able to connect via IP is not evidence that certficate was added correctly. Actually if you can access using your server’s IP address or Tor address, it means your issue is specific to .local.

Have you tried going to the process again? Also, what browser are you using?
I would suggest trying a second browser on the same device.

I have gone through the certificate process twice on my phone, however both times was using the same download of the certificate. I will download the certificate again from the server and try a third time.

I did try on two different browsers on my smartphone - Firefox Beta and Brave.

Helo there.

Can you also confirm that in your Firefox browser you have set security.enterprise_roots.enable to true in about:config as per guide step number 5?

The problem you’re encountering is related to mDNS (Multicast DNS) not working correctly on your CalyxOS device.

mDNS is a protocol that allows devices on a local network to discover each other using hostnames instead of IP addresses. In your case, it seems that your device is unable to resolve .local addresses, which are typically handled by mDNS.

One common cause of this issue is the use of VPNs (Virtual Private Networks). When a VPN is active, your device’s network traffic is routed through the VPN, which can prevent mDNS queries from reaching your local network. This is because the VPN essentially creates a separate network, and mDNS is designed to work within a single local network.

If you’re using a VPN on your device, you might want to try disabling it temporarily to see if that resolves the issue. If it does, you’ll need to look into VPN settings or choose a VPN that supports mDNS forwarding.

Please note that this issue is not related to StartOS, but rather to the network configuration on your CalyxOS device. If disabling the VPN doesn’t resolve the issue, you may need to investigate other network settings on your device or consult with the CalyxOS community for more specific advice.



Indeed this issue does seem to lie with some settings in CalyxOS, as I just borrowed my wife’s iPad and the local address works with that (as well as on my laptop).

I have NextDNS installed on my phone, however I have disconnected it with still no luck. The only other VPN shown in my phone settings is Orbot, however I have that disconnected as well.

It sounds like I need to start inquiring within the CalyxOS community for solutions.

Thank you everyone for your help thus far.

Okay, it looks like Android 12 could not resolve mDNS addresses per this thread.

It does look like it has been resolved with Android 13.

Unfortunately, the version of CalyxOS on my Pixel 4 is based on Android 12. Time to look into updating…

Some fine folks in the CalyxOS telegram channel helped me out, mobile data access was turned off in my CalyxOS Update Client (found in settings → apps → all apps → menu on top right → show system)