Unable to legacy-boot from USB HP EliteDesk 800 G3 Mini

Hi guys. I have been trying to install EmbassyOS on my refurbished HP EliteDesk 800 M3, 2tb Samsung EVO 870 Sata SSD, 16 gb RAM, i5-7500, but am running into issues with booting from the USB-flash drive in legacy mode. It seems like my computer will not recognize the flash drive in legacy mode, I can see the name of the flash drive under UEFI boot priority list, but under the legacy boot priority list it just says USB.

I have made the following changes in the BIOS:

  • Updated to most recent BIOS
  • Legacy Enabled and Secure Boot Disabled
  • Unchecked UEFI/EFI boot mode
  • Moved USB to the top of the boot priority list under legacy

I even bought a new flash drive to see if there was an issue with it. I made sure the flash drive was formatted to FAT-32, tried both free and non-free OS.

I plugged my new SSD into my regular computer, put in the flash drive and sucessfully installed EmbassyOS on there. Then unplugged everything instead of rebooting to continue the setup of EmbassyOS, switched the SSD back into the EliteDesk, and tried to legacy boot the SSD, but no luck. The OS will not be recognized…

Any tips and tricks to get this to work?
I only want to run Bitcoin core and Electrum server to use with Sparrow Wallet. Wil probably look to use Umbrel with Ubuntu if I cant get this to work ASAP.

Hello there. Have you used our guide for flashing StartOS? FAT-32 is not recommended format. Use balenaEtcher for flashing. Mayb this will help.

Yeah, I followed the guide. I used belenaEtcher for flashing. I believe I tried formatting the flash drive to NTFS → flash using belenaEtcher → attempt boot, and the same with FAT-32. So I have had no luck, no matter the flash drive format.

Might give it another go tho, making sure it is NTFS before with belenaEtcher. Cant remember if I did that after figuring out how to enable legacy boot.

After reading more into the disadvantages of running a node on Umbrel, I will def continue trying to get StartOS up and running. Next move will be to make sure the flash drive is NTFS-formatted.

If you use balena etcher, formatting before that does not change anything. When flashing the image on your drive it takes the format and filesystems of the raw image, so it will become EXT4 (IIRC) anyway.

Do you really need to boot in legacy mode? I got everything running in a VM under UEFI (secure boot disabled) just fine.

Hmm. Come to think of it, when I first tried to install it, I misunderstood the instructions and flashed the SSD with the image, and it booted in UEFI and got to the point where I would choose which storage unit to install the OS to. But at that point I could only choose to install it to the USB drive, which is not recommended (?).

UEFI boot with the StartOS flash drive gets me to an error message, the same one every time. I will try to do it again and post an image of it.

I managed to install StartOS just now. The solution was very simple. Followed the guide for flashing my USB drive. Plugged it into the computer. Went into BIOS by pressin F10 repeatedly, restored the BIOS to factory default. Saved and exited, entered BIOS again upon the automatic reboot by pressing F10 again. Went to boot options under the Advanced tab, made sure the UEFI-boot order was set to USB at the top of the list under UEFI. Then the crucial part that made the installation successful: I went to the Advanced Tab, to “Secure boot configuration” and under Configure Legacy Support and Secure Boot I choose “Legacy Support Disable and Secure Boot Disable”. Then went back to the Main tab, and saved and exited.

After that the PC successfully booted via the USB and I am now installing Bitcoin Core. Happy as ever!

Thanks for the help @remcoros. I read so many places that I had to do a legacy boot, and never thought to try UEFI boot with secure boot disabled.

1 Like

Glad you got up and running. We do now support and recommend UEFI.