What exactly is 'backed up'?

When I run the backup on eOS, I get about a 4gb file. I assume that this is just the OS and its programs since I have about 160gb of data in Nextcloud.

Is there a way to fully clone the machine to create a copy of the whole entire drive, thus backing up eOS, bitcoin core and all my data?

This doesn’t make sense. Can you check the backup report? It sounds like something failed. Bitcoin chain data is not backed up (since it can always be synced from the network), but all other service data generally is, along with OS data. Also, what is your backup setup?

Thanks for reaching out. I got this message today when I tried backing up again.

I’m looking for some permission in nextcloud about backups but I’m missing it.
I manually backup to an external drive I connect monthly.

update: I have not found anything to toggle or allow some permission to complete this full backup. The backup run by eOS is still 4gb.

Well this explains the problem. Nextcloud backup is failing, so its data is not included.

This should be fixed by using “System” → “System Rebuild” to rebuild the containers. This will not affect data, but it may take up to an hour to complete. Then try your backup again and let us know.

If I would do a complete re-installation of StartOS, and then I would use the backup to reset, would it reset everything in all apps and the OS?

I did the system rebuild. My backup has grown to 6gb now, but nowhere near the data on nextcloud. Nextcloud and simplex both give a checkmark but now its getting hung up on vaultwarden and does not complete the backup. I’m out of ideas.
Did a backup this evening:

Now I’m going to vent: running a personal server is frustrating and I just want it to work like g-drive and bitwarden on the web.

Are you asking if you do a Restore from Backup, would all services be restored? If so, the answer is yes. Your existing configurations and data would be carried over.

We’re getting there, but some patience are required for rare hiccups like this one. Have you updated to v0.3.5.1 yet? Also, what hardware are you running on?

Dave, somewhere between v3.5.1 and another rebuild the issue has been fixed. I did another backup last night and NextCloud took longer than 30 min (vs. 20 seconds). I now have a backup file that looks like it got everything at 168gb.

I’m running on a mini-pc (trigkey) Ryzen7 with 32gb ram and a 2tb nvme drive.
I’m starting to wonder if the hardware could be an issue with some of the weird things. For example I can rarely see the marketplace, sometimes it works in the onion browser going to the .onion site. Sometimes it gives me a warning that the request failed. Sometimes it says an overactive web browser or addblocker/antivirus so I’ve been tinkering with the firefox settings. What I cant figure out is how an addblocker or maybe bitdefender on my windows 11 machine would/could impact fetching software upgrades or talking to your machines.

Great to hear!

It’s definitely possible for adblockers, VPNs, firewalls, or various networking schemes to interfere with your ability to use your server. It is also possible for hardware to cause problems in some cases, but you are not resource-bound by the sound of it. If any of these jumps out at you, try eliminating them one at a time.