0.3.5 update gone wrong

Hi there,

Two days ago I noticed that an update (v0.3.5) was available and I went for it. After the update was downloaded i received a message to restart the server, once I click to restart i receive a message “Gateway timeout”. So far so good, this should be expectable.

After waiting for approx. 1h and the system not coming back up online I restarted the server but no luck.

I connected a monitor to it and i saw the following error:

To try and fix this, I inserted my bootable StartOS pen and tried to reinstall StartOS. No luck with that either.

Next i downloaded the v0.3.5 .iso from Github, flashed the pen with it and reinstalled StartOS again and now I see the following:


I’ve run out of ideas of what to do without wiping out all data.
Any help is appreciated :bowing_man:

PS.: I’ve tried the “SYSTEM REBUILD” option.

1 Like

Came here to post this exact thing. Also happened to me when I tried to update tonight. Can’t even re-flash. Laptop doesn’t even recognize the storage hardware anymore, it seems.

Hi, sorry about the delayed response here, looks like this got missed.

The “cannot downgrade” is a bad error message, unfortunately. It just means you are coming from an older version. StartOS had a cliff version at 0.3.4 so we deleted the 0.3.3 migrations from the code. You are likely coming from or earlier, which means you will need to reflash before going on to

This is likely unrelated to the issue above. Can you provide some more information about what exactly you are experiencing? Are you saying you have the exact same error message and tried the exact same steps to resolve, or is your situation different in any way?

When you say “you will need to reflash before going on to”, do you mean I need to do a clean install or does reinstalling option (keeping data) works also? Thanks

Do a re-install, keeping data, as opposed to factory reset, which would wipe data.

It worked :tada: I’ve got the system back.

Now I will trigger the update once again and see how it goes. :crossed_fingers:

Done, fixed! Thanks @matthill and @start9dave :bowing_man:

1 Like

Originally, I did have the same symptoms as Nunosav, but not the same message. I wasn’t able to grab a screenshot of that, but I have since tried to re-install from USB flashdrive and I am getting these errors messages on command line. Tried flashing both and (hotfix).

Are these just messages in your log, or do you have other issues stemming from this? It looks like you may have some peripheral devices attached that are not needed. Either way, this probably warrants a new topic with the context and details, please.

1 Like