After installing StartOS on laptop (from USB dongle), it cannot boot

After installing StartOS, I get an error message that the system cannot boot because there is no drive.
I found a very similar issue to mine here, but his solution didn’t work for me:

And also a related issue may be this one but I’m not sure:

I tried changing to Legacy boot (security disabled), but it didn’t work for me. And I see in the BIOS that the Legacy option is still completely empty.
When I try to install Ubuntu to the disk, I can boot to it normally. Then I tried StartOS again, and again I get the same boot problem.

I’m using Dell Latitude E5450, and flashed the “nonfree” version of the OS.

What else can I do?

Hello, thank you for posting and sorry for the trouble you’re having in booting up StartOS on your Dell Latitude machine. I actually did the same on a Dell Latitude E6530. My experience was pretty similar to yours. Have you wiped the existing partition on the drive? If not, I would suggest looking into doing so and creating a new one (use exfat), as that has been a known solution to similar issues such as this. This being a DIY implementation, it will require some fiddling, but we are happy to review results and make further suggestions as you experiment.

Of course partitions were recreated from a state of having nothing on the UEFI boot list… When I installed Ubuntu they were created.
What else can we try?

Hey Some1!

First let me welcome you on board!

Now if you can navigate in the disk BIOS settings at SATA configuration section and check If the current mode is set to RAID or IDE and change it to AHCI.
Save the changes and exit the BIOS.

Let me know if this worked.

Thanks for the reply! I already tried solving the problem by installing Umbrel OS, which seems to be working fine so far and in the process of syncing. It is also able to install the whole thing (OS+data) on the external SSD (with StartOS I had to install the OS on the internal drive first).

Your reply might help someone who’s stuck in the same place as I was. But I think you should reconfigure the way StartOS installs the boot section, because it’s the only OS that creates these sorts of boot problems.


1 Like

I never did get mine to work. I am currently using Umbrel too and am waiting for the new release of StartOS as I was told it was a kernel compatibility issue with my newish NVMe SSD.

hello , I am having a similar problem , I had start 9 os running with some issues, and decided to reinstall os and keep my data and now I am cannot get fresh install to boot
what os version should I use

If you have a x84 chip, then the x84 version. If you have a DIY machine, then the non-free version.