BootDevice Not Found after installing EmbassyOS on HP EliteDesk 800

I followed the guide for installing EmbassyOS on x86 machines. After the successful install prompt, I removed the USB stick and clicked Reboot.

After reboot, I get this message:

BootDevice Not Found
Please install an operating system on your hard disk.
Hard Disk - (3F0)

I tried reinstalling EmbassyOS, same issue. Then I tried installing Ubuntu and it installs without any issues. When I try to install EmbassyOS again, I get the “BootDevide” Not Found screen again.

Anyone can help?

Do you have multiple disks? If so, maybe disconnect any that you did not install to

Unfortunately there is not a lot of information to go on here. Perhaps you could provide as much info as you can about your specific hardware and firmware so we can get an idea where the issue may be.

Thanks

Sorry, I’m not a very technically advanced user. I have followed as many tutorials as I could to get this far. Here is as much info as I can give:

I flashed Ubuntu 22.04 LTS on a HP EliteDesk 800 G2 with one SSD of 1tb, 16gb or RAM DDR4 and an Intel Quad-Core i5-6500T.

In order to flash EmbassyOS, I went into the BIOS and Disabled Secure Boot and made sure the USB drive was first in the Boot Order.

After the Successful Install prompt, I removed the USB stick and clicked on the Reboot button. When the computer rebooted, I was stuck on that black screen giving me the “BootDevice Not Found” as if I didn’t have any operating system installed on the hard disk.

Apart from this, is there any other information that you would need?

I really appreciate your help!

Are you in EFI or UEFI boot mode? You will need to change to Legacy in your BIOS if so. This may be the issue

1 Like

That was exactly the issue. Once I switched the Boot Option to “Legacy Enabled and Secure Boot Disabled”, everything worked perfectly! :slight_smile:

Should I now leave the Boot Option permanently to this? Or should I include Secure Boot as well?

Thank you so much for your help, love this community already! :grin:

1 Like

Secure Boot is usually for Windows systems iirc, but read up with your BIOS manufacturer, I could be wrong. Leave it in Legacy boot. Glad you’re up and running!

1 Like