Can not view marketplace unless in kiosk mode

I’ve tried both Tor and standard Firefox and Brave browser for connecting to my server and having trouble accessing updates and Marketplace. I have no issues when in kiosk mode however. I’m thinking a connection is somehow blocked because sometimes the cloud icon is not dark with a check however, I show connected. On a few occasions, I received the following message. Most of the time it just sits there and ‘spins’. I can access system and services.


I’m also having the same problem when it shows I’m fully connected. This is true over .onion or .local
image

Hi @stephenInGeorgia

The first steps might be quite obvious, and you might have already tried them. But have you hard-refreshed the browser window?

To perform a hard refresh in Mozilla Firefox on different operating systems, you can use the following methods:

Windows:
    Hold down the Ctrl key and press F5.
    Alternatively, you can also use Ctrl+Shift+R to perform a hard refresh.

Mac OS X:
    Hold down the Shift key and click the Reload button on the toolbar.
    Alternatively, you can use Command+Shift+R to perform a hard refresh.

Linux:
    Hold down the Ctrl key and press F5.
    Alternatively, you can use Ctrl+Shift+R to perform a hard refresh.

If that doesn’t work, the obvious next step would be to pay very explicit attention to the message shown. Do you have any extensions set up in the browser that could be blocking anything? Could you turn them all off them reactivate them one by one while trying to connect to the marketplace?

Thanks for the info. I’ve tried the hard refresh but still same problem. I’ve got everything removed on Firefox that I can find. I’m kinda at a loss of how to proceed if this is going to be a pain to use.

Hey @stephenInGeorgia, sorry about the issues you’re facing. We know it can feel frustrating but the team is here to help and loves to get users unstuck whenever possible. Since you’re having success viewing marketplace in kiosk mode but not on your client device, the issue may potentially be related to your network. Would you be able to confirm your network setup? We are also looking into that connection status that you described in your first message. Let us know and thank you for your patience.

1 Like

I have disabled or allowed just about everything regarding the .onion address and .local address. I stop my VPN, I have allowed both firefox and tor for bitdefender. My eOS is connected directly to my router. My PC is upstairs connected via an ethernet over power connector. I know there is something connection-wise going on or some blocker. Most recent example trying to update simplex server:

It’s almost like anything the server has to access the internet for is timing out.
Could my ISP be somehow blocking it? But that is not logical because in kiosk mode its all bueno.

Thanks for the additional information. It sounds like there are definitely some factors at play that could cause issues here. I suspect that your network is to blame here because we very rarely have network issues like this reported (and when we do, we ultimately discover it is due to the user’s network). I would start by plugging your PC into the router directly (to rule out the eth-over-power causing a problem), and then turn off, or give a clear ethernet port to, both devices.

The error you listed is helpful as it lists a DNS resolution issue to our registry.start9.com domain. I would guess you are doing something at your router with DNS that would be causing this. Doing the above tests should verify this. While it is possible for your ISP to interfere with your traffic, it is extremely rare and we have not had any widespread reports of this.

1 Like

Dave, not sure if this would be a new thread or not.
I’ve completely re-wired my entire network with new wires (got a nice speed bump as well).
I have no issues connecting to the server, but accessing the registry or looking for updates most often fails.

Are there some optimal settings in Firefox to not mess with this? Maybe turn off DNS resolution.

This is not going to be a Firefox issue, and messing with anything in the browser is likely an exercise in “barking up the wrong tree.” Unfortunately we cannot support all the possible custom network setups (as you can imagine). We would need a lot of details in order to give any advice here.