Having start9 isssues would like to reinstall

Running start9 on a dell laptop, for a while with out issues but now having issues doing backup, updates and installing app, would like to uninstall start9 and then reinstall it , hope this well resolved issues Is there a correct way to do these steps to uninstall and reinstall stat9


Before you reinstall StartOS on your Dell, could you share some more details about your Hardware Configuration and what the Health Checks of your installed Services are saying (are they all green)?

Might be necessary to do a full reflash of the OS.

my mistake using a Lenovo T550 2tb, health checks are green, here are some errors I get when doing updates and other operations

RPC ERROR: Network Error error sending request for url (https://registry.start9.com//eos/v0/latest?server-id=273a23bf-17ee-4c89-a9ae-8e1da37ee23f&os.version=>%3D0.3.0+<%3D0.3.5.1&os.arch=x86_64&hardware.arch=x86_64&hardware.ram=8011120640&hardware.device.processor=Intel(R)+Core(TM)+i7-5600U+CPU+%40+2.60GHz&hardware.device.display=HD+Graphics+5500): connection error: error:0A0003FC:SSL routines:ssl3_read_bytes:sslv3 alert bad record mac:ssl/record/rec_layer_s3.c:1586:SSL alert number 20


RPC ERROR: Network Error error sending request for url (https://registry.start9.com//eos/v0/latest?server-id=273a23bf-17ee-4c89-a9ae-8e1da37ee23f&os.version=>%3D0.3.0+<%3D0.3.5.1&os.arch=x86_64&hardware.arch=x86_64&hardware.ram=8011120640&hardware.device.processor=Intel(R)+Core(TM)+i7-5600U+CPU+%40+2.60GHz&hardware.device.display=HD+Graphics+5500): connection error: error:0A0003FC:SSL routines:ssl3_read_bytes:sslv3 alert bad record mac:ssl/record/rec_layer_s3.c:1586:SSL alert number 20

What version of StartOS are you running? These are both the same error messages. Are you seeing them while trying to update StartOS? Have you tried powering everything down and restarting. Also, for back and forth trouble shooting, telegram is probably the better means of communication (if you use it). The link is Telegram: Contact @start9_labs

version 0.3.5, same error for any type update, don’t care for telegram, there are a lot of fake people there, in my opinion. but may try it one more time

So you have green health checks? but you can’t update. Do your services work? Are you able to connect over your LAN and Tor. Did you go through the steps to trust your Root CA? etc. These are the first things to check. I would eliminate the possibility of this being a network issue before reinstalling everything.

LAN and Tor are working , all network connections seem to be working ,

You can try system rebuild in the system → power → rebuild if you continue to have consistent errors and you are sure its not just your network. If you want to reinstall without loosing your data, you can flash the latest StartOS on a thumb drive and boot from it. Make sure you choose use existing drive if you don’t want to lose your data. I will leave links for the flashing guide and the use existing drive guide.
Flashing guide for os-x86

Guide to reinstall StartOS using existing drive

I have tried system rebuild a couple to times and powered down as well,

ok thanks for your help

1 Like

Did you end up getting back online? Normally these are transient networking errors and can be fixed with a hard refresh. If not, then you may have an issue in your networking stack somewhere, such as a custom firewall, VPN, or a setting in your router. You can also try to restart the router.

Finally getting time to work on this issue again, tried a refresh with no improvement, don’t have any firewalls , I reset my router, I’m using a Starlink router and disk , don’t have any issues downloading with my other computers , BTC core is staying updated and 100%, if I decided to do a hard reset will have to down BTC block chain all over again or can I keep what I have,

If you mean hard refresh, no, that is just basically clearing your browser cache. Caching issues are very common and hard refreshing your browser can be done often. To perform a hard refresh on different platforms, you can follow these specific key combinations:

  • Linux/Windows: Press Ctrl+Shift+R.
  • macOS Firefox: Press Cmd+Shift+R.
  • macOS Safari: Press Cmd+Option+E to clear the cache, then Cmd+R to refresh.

I’m not sure I following you , I refreshed start9 os that my laptop is running by reinstalling it and using the data that I have , is the browser running in the background and what browser is it.

By hard reset, I didn’t know if you were referring to reflashing your device or if you meant hard refreshing your browser. I was just pointing out that hard refreshing your browser is a good trick to know that solves a lot of connection issues. are you still having other problems

If you are talking about reflashing your device and still preserving all your data you can do that following our guides. First flash StartOS onto a usb drive using this guide.

Then when you reboot, make sure you select “recover” then “use existing drive” following this guide Start9 | Use an Existing Data Drive

In this case you would not need to re-sync the blockchain

I did the reflash and recovery but I’m still having the same problem with apps not updating, there doesn’t seem tri be any connection issues,
Not sure if doing a fresh reflash will make a difference, or not

Are you saying that StartOS shows that you have updates available for some of your services, but when you try to update them, the update fails?

That is exactly correct,

What error message are you getting or any other details you can provide would be helpful. Also, which services exactly are you trying to update?